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Introduction
Welcome to Sonic Foundry Vegas Pro™

Sonic Foundry proudly introduces Vegas Pro, an innovative and technologically advanced 
multitrack media editing system. Vegas Pro was designed with one thing in mind: to create a 
more efficient audio/video production environment without sacrificing the exceptional 
quality and superior processing power professionals expect from Sonic Foundry. 

Vegas Pro removes the barriers commonly found between your creativity and sophisticated 
multitrack recording and editing. Whether it’s the standard and familiar Windows 
navigation commands, or the clean and uncluttered interface throughout, you’ll find Vegas 
Pro a tool that will be mastered in minutes. But don’t let that fool you. Beneath the Vegas 
Pro unique and customizable interface, you’ll find a product so powerful and flexible, you’ll 
forget you’ve just completed your project in half the time. 

Below are some of the features available in Vegas Pro, the perfect multitrack media editing 
system for your studio or production environment:

Non-destructive editing Unlimited tracks 
Unlimited undo/redo Multiple file formats (.wav/.aif) on a single track
Automatic crossfade functionality EQ and compressor inserts available on every track
Quick-edit media trimmer with direct link to 
*.wav editor

Simultaneous multitrack record & play

Loop recording Plug-In manager
Real time event resampling 32 assignable DirectX FX sends 
Audio/video scrub control DirectX Plug-In support
Video preview window Dual processor support
Edit detail list management Multiple I/O support
24-bit/96 kHz MIDI Time Code generate & chase
26 Aux outputs Dual monitor support
Internet streaming file authoring (Windows 
Media Technologies 4.0 and RealNetworks G2)

Ability to incorporate timeline metadata (markers/
captions) for Internet content authoring

Imports: .wav, .aif,  .avi, .mov (using Microsoft 
DirectShow), .mpg (video), .bmp

Exports: .wav, .aif, .avi, .wma, .asf, .rm, .mp3 
(with optional plug-in)
INTRODUCTION
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System requirements

Your system’s components affect how well Vegas Pro performs. 

Common

• Microsoft® Windows™ 9x or NT 4.0
• CD-ROM drive
• 20 MB hard-disk space for program installation
• Windows-compatible sound card
•  Internet Explorer™ 4.0 (included on CD-ROM) or later to view online help 

Minimum

• 200 MHz processor
• VGA display
• 32 MB RAM
• DirectX Media 6.0 (included on CD-ROM) or later 

Recommended

• 400 MHz processor
• 128 MB RAM
• 16-bit color display

Technical Support

If you experience problems or have questions while using Vegas Pro, there are a few ways to 
get the information that you need from Sonic Foundry: Web site support, Email support, Fax 
support, and Telephone support. 

Web site support

Visit our Web site at www.sonicfoundry.com/support. You will find technical information, 
reference information, program updates, tips and tricks, and a Frequently Asked Questions 
(FAQ) archive. 

Email support

Send your questions or comments to support@sonicfoundry.com. Our Technical Support 
Department will respond to you within 36 business hours. 
INTRODUCTION CHP. 1
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Fax support

Send your questions or comments via fax 24 hours a day at (608) 256-7300. You will receive 
a response within 36 business hours.

Telephone support

Our technical support representatives are available Monday-Friday from 8am to 7pm (CST) 
at (608) 256-5555.

Before You Call Support

Before you contact our technical support department, we ask that you do the following:

• Check to see if your question may be answered in the manual or online help. 
• Use a telephone that is near the computer where Vegas Pro is installed.
• Make sure you have registered the product. For more information, see Registration on page 

13.

 Installing Vegas Pro

Before you install Vegas Pro, we recommend that you exit all open programs and temporarily 
disable any virus protection. 

1. Insert the Vegas Pro CD-ROM. The Vegas Pro Installation screen appears (if CD-ROM 
AutoPlay is enabled).

If the CD-ROM AutoPlay is disabled, click on the  button and choose Run. 

In the Run window that appears, type the CD-ROM drive’s letter and add :\setup.exe. 
Click the OK button to start the installation.

2. Click Install Software. The installation process begins.

3. Follow the screen prompts and enter the necessary information when required. 

• Use the  button to continue the installation.
• Use the  button to suspend the installation and review previous screen prompts.
• Use the  button to terminate the installation process.

4. At the last screen prompt, click the  button to conclude the installation.
CHP. 1 INTRODUCTION
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Starting Vegas Pro

Starting Vegas Pro is exactly the same as starting most Windows programs that you may use 
already. After Vegas Pro has been installed on your computer, there are two ways to start the 
program. 

Using the shortcut

You may have noticed a new icon on your desktop ( ) upon completion of the installation 
procedure. This icon is a shortcut to the Vegas Pro program located on your hard drive. By 
double-clicking on this icon, you will start Vegas Pro directly from the desktop.

Using the Start button

The second method to start also allows you to start Vegas Pro right from the desktop. This 
procedure is exactly the same as other Windows-based programs. 

1. Click the  button on the task bar. The Start menu appears.

2. From the Start menu, choose Programs. The Programs list menu appears.

3. From the Programs menu, choose Sonic Foundry Vegas. A sub-menu appears.

4. From the sub-menu, choose Sonic Foundry Vegas to start the program. The registration 
dialog window appears. (Once you register Vegas Pro, this dialog will not appear again.)

5. Enter either the serial number or the activation code and click  to start using 
Vegas Pro. 

This graphic displays the default location where Vegas Pro was installed.
If you specified a different directory during installation, then navigate
to that directory via this menu.

Enter either the serial or 
activation code here
INTRODUCTION CHP. 1
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Serial number and activation code

The first time you start Vegas Pro, the registration dialog appears. You need to enter either 
the serial number or the activation code. Either number will start Vegas Pro so that you may 
immediately begin your first project.

The serial number allows you to run Vegas Pro for 7 days. After the 7 days expire, Vegas Pro 
will time out. If you purchased Vegas Pro, you can receive your activation code by registering 
either online or by telephone.

Note: If you have started a project and Vegas 
Pro times out, you will not lose the project. It 
will be available when you start the program 
after you have registered, received, and entered 
your activation code.

An activation code is based on the Computer ID number where Vegas Pro is loaded. Each 
computer has a unique number, similar to a license plate. An activation code is created 
based on that unique number. When you register Vegas Pro, Sonic Foundry will generate an 
activation code for you. Once the activation code is entered, Vegas Pro will not time out; it 
is yours. Because the activation code is based on the Computer ID, it is important that you 
have Vegas Pro loaded on the computer where you will be using it. 

The Computer ID is automatically detected and provided to you when you install Vegas Pro.

Registration

The registration dialog that appears when you start Vegas Pro allows you to quickly and 
easily register to get your activation code. You may register via the Sonic Foundry web site or 
via the telephone.

Registering online

When you register online, your activation code is sent to your email address within minutes 
after you complete and submit the online registration form. 

To register online, do the following:

1. Select the second radio button labeled I would like to register online.

2. Click the  button. Your internet browser automatically starts (if it is not already 
running) and the Sonic Foundry online registration form appears. 
CHP. 1 INTRODUCTION
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3. Fill in the form’s required fields, which are indicated with an asterisk (*). You will notice 
that some of the information is already inserted for you, most notably the Computer ID 
number.

4. Make sure that your email address is entered correctly. This address is where the 
activation code will be sent.

5. Submit the form to register. In a few minutes, your activation code is sent to your email 
address.

6. Copy the activation code from the email message and paste it into the registration field 
on the Vegas Pro Registration dialog.

7. Click the  button to activate Vegas Pro and become a fully registered customer.

Registering via the telephone

When you register via telephone, a Customer Service Representative will help you to obtain 
your activation code.

To register via telephone, do the following.

1. Select the third radio button labeled I would like to register over the phone.

2. Click the  button. A new dialog will appear with a field where you will enter the 
activation code. Your Computer ID number appears below this field.

3. When the Customer Service Representative gives you the activation code, type it in the 
field.

4. Click the  button to activate Vegas Pro and become a fully registered customer.

Using the online help

Vegas Pro includes HTML online help. To view the online help, you need to have Internet 
Explorer 4.0 or higher loaded on your system (included on the Vegas Pro CD-ROM).

Enter activation code

Computer ID number
INTRODUCTION CHP. 1



15
Accessing help

The online help is available in two forms: in a Main help window or What’s This? help 
window. Both forms are available via the keyboard or the Help menu.

Main help window

The Main help window is accessed either by choosing Contents and Index from the Help 
menu or pressing the  key. This window has three tabs that you can use to find the 
information that you need.

The Contents tab provides a categorized listing of available help topics. Click on the book 
( ), then on the topic page ( ) you want information about.

The Index tab provides a complete listing of the help topics available. Use the scroll bar to 
scroll through the list of available topics or type a word in the text field to quickly locate 
topics related to the word. Select the topic and click the  button.

The Search tab allows you to enter a keyword and display all of the topics in the online help 
that contain the keyword you have entered. Type a keyword in the text field and click on 
the  button. Select the topic from the list and click the  button.

What’s This? help

What’s This? help allows you to view pop-up window descriptions for Vegas Pro menus, 
buttons, and dialog boxes. Choose What's This? from the Help menu or press the  
keys, and then click on any Vegas Pro item. To use What’s This? help in a dialog box, click 
on the question mark ( ) in the upper-right hand corner of the dialog box, then on an item. 

Tip of the Day

The Tip of the Day displays functional tips to increase your productivity with Vegas Pro. To 
view and scroll through the Tip of the Day messages, choose Tip of the Day from the Help 
menu.

F1

Toolbar
Contents

Information
pane

Index tab

Search tab
tab

Shift + F1
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PDF manual

There is a more current manual available on the Vegas Pro CD-ROM. The PDF manual 
contains information that was written during this manual’s press time. To view this manual, 
you will need Adobe® Acrobat® Reader (also included on the Vegas Pro CD-ROM).

Help on the web

Additional Vegas Pro help and information is available on the Sonic Foundry web site. 
Choose Sonic Foundry on the Web from the Help menu to view a listing of web pages 
pertaining to Vegas Pro and Sonic Foundry. If your browser is not already open, Vegas Pro 
will automatically start it for you.

Overview

Vegas Pro is designed to be an easy-to-use program with many tools that provide power and 
flexibility when creating and working with media files. As you will learn, many of the Vegas 
Pro operations, menu items, and shortcut keys are common to other popular software 
applications. 

Vegas Pro is a unique and powerful program that gives you tremendous flexibility. The 
following sections are a graphical tour of the Vegas Pro work area. Please take a moment to 
get familiar with the Vegas Pro interface. Many of the procedures in this manual use 
terminology found in these sections. 

Main window

This is the window that appears when you open Vegas Pro. The work area is primarily three 
frames: the Track List, the Track View, and the Window Docking Area. The other parts of 
the interface are tools and features used while working with your project. 

Menu Bar

Toolbar

Time Display

Track List

Scrub Control

Window
Docking 
Area

Video Ruler

Marker Bar
Ruler

Track View

Transport Bar
Explorer (shown)
Mixer (shown)
Trimmer
Video preview
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Toolbar

The Toolbar allows you to quickly access the most commonly-used functions and features in 
Vegas Pro.

Marker bar

The Marker bar is the area where informational tags may be placed, named, and positioned 
along the project’s timeline.

Create new project Redo command

Open existing project Enable snapping to grid lines

Save project Automatic crossfades

Open project properties Ripple edits

Cut selected events or time range Edit tool

Copy selected events or time range Envelope tool

Paste items from clipboard into project Selection tool

Undo command Zoom tool
CHP. 1 INTRODUCTION
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Ruler

The Ruler is the timeline for your project. You may specify how the Ruler measures time: 
seconds, measures and beats, frames, etc.

Track List

This list identifies the track order in your project. Each track’s controls are also available in 
the Track List.

Right-click 
on Ruler

Track controls

Track Number
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Track View

All arranging and editing is done in the Track View. This area contains all the project’s 
events.

Transport bar controls

The Transport bar contains the playback and cursor positioning buttons frequently used 
while working on your project.

Scrub control

The Scrub control is used to play your project forward or backward for editing purposes. You 
may adjust playback speed by setting the Speed Control Marker located beneath the Scrub 
control.

Record into track Stop playback

Loop play back Move cursor to start of project

Play back from beginning of project Move cursor to end of project

Play back project from cursor position Move cursor left at grid increments

Pause project playback Move cursor right at grid increments

Track View

Set play-

Click and drag either forward

back speed

or backward for playback
CHP. 1 INTRODUCTION
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Window Docking Area

This area allows you to keep frequently-used windows available, but out of the way while you 
are working with a project. To dock a window, simply drag and drop it to the Docking Area. 
This area has three regions in which a window can be placed: right, middle, and left. As a 
result, the Docking Area can display up to three windows at a time.

When windows are docked, they will either be displayed on top of the other windows, or 
each window’s tab will appear above the task bar. Simply click the window’s tab to bring it to 
the top. 

Explorer window

The Explorer window works similarly to the Windows 9x and NT file management Explorer 
included with your operating system. Use the Vegas Pro Explorer window to select media 
files to place into your projects.

One window display

Two window display

Three window display These windows are fully
scalable to suit your needs.

Click a window’s tab to 
bring it to the top.

Select drive 

Preview selected
media file before
you place it
in the project

or folder

Select media to place 
in the project by dragging
and dropping or 
double-clicking
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Video Preview window

This window displays a project’s video event during project editing and playback. If a video 
event is not a placed in the project, you will see “--No Video--” in the center of this window.

Trimmer window

The Trimmer window is a good place to edit an audio event. When an event is placed in the 
Trimmer window, you may take portions of the event and place them on separate tracks by 
dragging and dropping. For more information, see Using the Trimmer window on page 118.

Mixer window

The Mixer window gives you access to your project’s properties, bus assignments, output 
levels, and FX chains.

Video will appear during
project playback or as
the cursor is moved 
during editing.

Right-click to 
change Video
Preview settings

Trimmer window
Transport bar

Right-click on a 
meter to change
its settings
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Keyboard command reference

Vegas Pro keyboard commands are shortcuts that you can use while working with your 
project. 

Project file commands

Window view commands

Edit commands

Create new project Ctrl+N

Open existing project or media file Ctrl+O

Save project Ctrl+S

Open project’s properties Alt+Enter

Exit Vegas Pro Alt+F4

Track view Alt+0 Edit Details Alt+4

Explorer Alt+1 Plug-ins Alt+5

Trimmer Alt+2 Video Preview Alt+6

Mixer Alt+3

Undo Ctrl+Z or 
Alt+Backspace

Select right by grid marks Shift+Ctrl+Page Down

Redo Ctrl+Shift+Z Restore selection Backspace

Cut selection Ctrl+X or 
Shift+Delete

Paste repeat from clipboard Ctrl+B

Copy selection Ctrl+C or 
Ctrl+Insert

Split event(s) S

Paste from clipboard Ctrl+V or
Shift+Insert

Trim/Crop selected events Ctrl+T

Select all Ctrl+A Open in Sound Editor Ctrl+E

Unselect all Ctrl+Shift+A Mix to new Ctrl+M

Delete selection Delete Mix to preview Ctrl+Shift+M

Select left by grid marks Shift+Ctrl+PageUp Make a selection during play back I (in) and O (out)
INTRODUCTION CHP. 1
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Cursor placement commands

Playback commands

Event commands

Track view commands

Go to beginning of selection 
or view (if no selection)

Home or W Center in View \

Go to end of selection or view 
(if no selection)

End or E Swap on selection Num. pad 5

Go to beginning of project Ctrl+Home Move left to marker(s) Ctrl+Left (arrow)

Go to end of project Ctrl+End Move right to marker(s) Ctrl+Right (arrow)

Move left by grid marks Page Up Move left to event edit points 
including fade edges

Ctrl+Alt+Left 
(arrow)

Move right by grid marks Page Down Move right to event edit points 
including fade edges

Ctrl+Alt+Right 
(arrow)

Go to Ctrl+G

Start/stop playback Spacebar Pause Enter

Stop playback Esc Record Ctrl+R

Looped playback L Play back from any window Ctrl+Spacebar or F12

Move selected event(s) one 
pixel

Right (arrow) 
number pad

Move selected event(s) down one track Down (arrow) 
number pad

Move selected event(s) one 
pixel

Left (arrow) 
number pad

Move selected event(s) right on grid Ctrl+Right (arrow) 
number pad

Move selected event(s) up 
one track

Up (arrow) 
number pad

Move selected event(s) left on grid Ctrl+Left (arrow) 
number pad

New audio track Ctrl+Q Group selected events G

Enable/disable snapping F8 Mark in point I or [

Snap to markers Shift+F8 Mark out point O or ]

Snap to grid Ctrl+F8 Insert/Remove track-volume envelope V

Ripple edit mode Ctrl+L Insert/Remove track-panning envelope P

Auto crossfade mode X Insert Region R

Edit tool selection D Insert Marker M

Normal edit tool Ctrl+D Insert Command Marker C
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View commands

Miscellaneous commands

Increase track height Ctrl+Shift+Up 
(arrow)

Zoom out large increments or selection 
(if one exists)

Ctrl+Down 
(arrow)

Decrease track height Ctrl+Shift+Down 
(arrow)

Zoom in large increments or selection 
(if one exists)

Ctrl+Up 
(arrow)

Zoom in time (incremental) Up (arrow) Zoom in vertically Shift+Up (arrow)

Zoom out time(incremental) Down (arrow) Zoom out vertically Shift+Down (arrow)

Online help F1 Popup menu Shift+F10

What’s This? help Shift+F1 Refresh screen F5
INTRODUCTION CHP. 1
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Signal Flow

Audio event Normalize event Event ASR

Auxiliary send Track FX

Track fader

Pan track

Mute track

Assignable FX send

Input Chain

Output Mute

Master 

FX Mute

Hardware

Fader

Bus Assign.

 output

Pre/Post vol. Pre/Post vol.

Assignable FX

Bus Control

Bus Assign.
CHP. 1 INTRODUCTION



26
INTRODUCTION CHP. 1



CHP. 2

CHAPTER

27

2

Quick Start
The Vegas Pro environment is a new way of thinking in multitrack mixing. Whether you are 
experienced at mixing or brand-new to it, you will find Vegas Pro easy to use and powerful. 
As you use Vegas Pro, experiment with different features and listen to the results in real- 
time. 

This chapter was designed to help you get familiar with the interface and describe the 
essential operations for using Vegas Pro. Using this chapter will get you into the program 
quickly to begin your first project or to begin experimenting with Vegas Pro. In the next 
chapter, we take you through a sample project from start to finish, using sample media files 
included on the Vegas Pro CD-ROM. For more information, see Tutorial on page 49.

Media Files

Before we get started in Vegas Pro, there are a few terms that need to be defined: 

• Media files - audio and video files that may be placed within your project.
• Events - playable portions of media files within a track. Events have fully editable starting 

and ending points. 
• Tracks - timeline containers where events are placed and arranged.

What type of media can you use?

A media file is an audio file that can be placed on a track or a video file that can be placed 
on the video ruler.

Format Name Extension Definition
Wave (Microsoft) *.wav Standard audio format used on Windows-based computers
Video for Windows *.avi Standard audio/video format used on Windows-based computers
AIFF *.aif Standard audio format used on Macintosh computers
QuickTime *.mov Standard audio/video format used on Macintosh computers (using Microsoft DirectShow)
Bitmap *.bmp Standard graphic format used on Windows-based computers
MPEG3 *.mp3 Highly compressed media file. This file type can only be placed via plug-in.
QUICK START
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A media file is referred to as an event after you have placed it on a track. Tracks are the 
containers for audio events. Each track can contain more that one event.

You may place events on separate tracks, or place all events on the same track:

In addition, you may place a video file on the Video Ruler. If the video has audio included, 
Vegas Pro automatically creates a new track and places the video’s audio on it. 

Starting a project

When you first open Vegas Pro, it displays an empty project. You may begin finding, 
previewing, and placing media files and start building your project. Vegas Pro supports many 
types of media file formats for placement, editing, and rendering to new media formats. 

The following sections briefly explain the process of finding media files, previewing them, 
and placing them within your project. 

Finding media files to use

There are two ways to find media to place in a project: using the Explorer window or the File 
menu and choosing Open.

The Explorer Window

The media Explorer window in Vegas Pro works similarly to the Windows 9x and NT file 
management Explorer included with your operating system. You can expand and collapse 
drives and folders in the tree view. The content of selected drives and folders appears in the 
list view.

Single track with Multitrack with 
single events multiple events

Video ruler with included
audio on track below.
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Note: If you cannot see the Explorer window, 
it may be “under” another window. Click the 
Explorer tab to display the window. If you do 
not see the Explorer tab, choose Explorer from 
the View menu to display it.

Using the Vegas Pro Explorer allows you to place multiple file types into your project 
simultaneously. To find media using the Explorer window, do the following:

1. From the drop-down list or tree view, choose the drive or folder where the media is 
located. 

Note: Vegas Pro is preset to display all 
supported file types. However, you may 
change the list view to display all files within a 
selected drive or folder.

2. From the list view, you may place the file into your project by dragging and dropping or 
double-clicking it.

Change view button
Auto-preview button
Stop preview button
Play preview button
Add to favorites folder
Delete selected items
Create new folder

Refresh view
Move up tree

Vegas Pro windows are dockable. To access
a hidden window, click its tab to bring 
it forward.
CHP. 2 QUICK START
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The File>Open option

An alternative to the Explorer window, you may find media in the more traditional method 
using the File menu and choosing Open. With the File>Open option, you specify the media 
file type that you want to use in the project: *.wav, *.avi, etc.

To find media using File>Open, do the following:

1. From the File menu, choose Open. The Open dialog appears.

Or, click the Open ( ) button on the Toolbar.

2. Select the media’s location in the Open dialog by doing one of the following:

• Specifying it from the Look in drop-down list.
• Double-clicking drives and folders in the list view.
• Typing the file’s path in the File name field.

3. Select the media format from the Files of type drop-down list.

4. Press the Open button to automatically place the file in the project.

Previewing a media file

Once you have located media files, you may preview them before placing them in your 
project. The Explorer window has a mini-transport bar with Play, Stop, and Auto Preview 
buttons( ). 

When you preview a file, its signal is sent to the Mixer window’s preview bus. This bus 
displays levels, which you can adjust with its Volume fader. 

To preview the audio file, do the following:

1. Select an event in the list view.

2. Press the Play ( ) button to listen to the file.

3. Press the Stop ( ) button, select a different file, or place the file in the project to stop 
previewing to the file.

Note: To automatically preview selections, 
press the Auto Preview ( ) button on the 
Explorer’s Transport bar. To turn off Auto 
Preview, press the Auto Preview button again.
QUICK START CHP. 2



31
Placing a media file on a track

Audio media files may be placed in your project by either dragging and dropping or double-
clicking them. Either method places the media file in its entirety in the Track View. After 
the file is placed, it becomes (and is referred to as) an event along the project’s timeline.

Dragging and dropping an event

This method controls the event’s occurrence on the Track View’s timeline. You can create a 
new track by dragging an event to a blank area in the Track View and dropping it in place. 
Vegas Pro tracks can contain multiple events, so you can place different events next to each 
other on a track.

In addition, you may place multiple events at the same time and control their arrangement 
in the track view. Vegas Pro is preset to place the events on separate tracks. 

To place multiple events, do the following:

1. Select a range of adjacent media files by holding down the  key and clicking files in 
the list view. 

Or, select files that are not adjacent by holding down the  key and clicking files.

2. Drag the files to the Track View.

3. Cycle through the placement options by right-clicking. As you click, Vegas Pro displays 
outlines of the selected events and the placement option. When you see the option that 
you want, drop the events in place. Below is a list of placement options: 

• Place events on separate tracks

• Place events next to each other on the same track

• Place events as takes on a track 

Shift

Ctrl

You will see one event on the track.
The other events are listed at takes “beneath” the 
the topmost event.
CHP. 2 QUICK START
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Double-clicking an event

This method creates a new track and places the event at the cursor’s position along the 
timeline. However, once the events are placed, you can move them from one track to 
another or change their position on the timeline.

Placing a event on the Video Ruler

A video media file may be placed in your project by either dragging and dropping or double-
clicking. The video is placed on the Video Ruler, located above the audio tracks. If the video 
file includes audio, the audio is placed below the Video Ruler on a newly-created audio 
track.

Dragging/dropping or double-clicking a video event

Video event placement is the same as placing an audio event; dragging and dropping 
controls timeline placement and double-clicking places the event at the cursor’s position. 

The Video Ruler supports one video event at a time. So, whether or not an event exists on 
the Video Ruler only affects what happens in your project when you place a video event. 
The following table describes placement scenarios: 

Event to place Video ruler status Placement method Result
Video only No event Drag/drop or double-click Video placed on ruler
Video with audio No event Drag/drop or double-click Video placed on ruler and audio on a new track
Video with audio event placed Drag/drop or double-click Audio on new track
Video with audio event placed Drag/drop to video ruler Video placed on ruler and audio on a new track
Video only event placed Double-click No affect (existing video is not replaced)
QUICK START CHP. 2
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Audio event basics

There are a number of ways to work with events once they have been placed in your project. 
Whether you are working to achieve a specific project goal, or experimenting with sound 
and video, the events that you placed are fully editable. The following sections describe 
basic event editing techniques. 

Moving events along the timeline

An event, by definition, is an occurrence along the project’s timeline. Events, as a result, 
may by moved along the timeline either individually or as a group. The left edge of an event 
is its starting point. Therefore, where the left edge lines up on the ruler determines when the 
event starts. 

Events may overlap each other or be placed on top of each other. You may crossfade 
overlapping events automatically or with envelopes.

Moving a single event

You can move an event along the timeline within a track or move it to a different track.

1. Select the event by clicking on it. The event is highlighted.

2. Click and drag the event along the timeline. 

If you move the event along the original track’s timeline, the event’s appearance (color) 
remains the same.

 

However, you may move the event to a different track’s timeline. If you do, the event 
appears as a simple outline and you will see its original track and position on the timeline. 
Once you release the mouse, the event will assume the new timeline position and track 
color.

3. Release the mouse to set the event’s timeline occurrence. 

4. Repeat Steps 1-3 to move more events along the timeline.

Original track position

New track and position
CHP. 2 QUICK START



34
Moving multiple events

You can move multiple events along the timeline within a track or move them to a different 
track, similar to the previous procedure. In addition, selected events do not need to be 
within the same track. You may select events on different tracks and move them as a group 
along the timeline.

1. Use the  key, the  key, or the Selection Edit tool  to select the events. For 
more information, see Selecting multiple events on page 49. 

2. Place the mouse cursor over one of the selected events.

3. Click and drag the events along their respective timeline(s).

If you move the events along their original tracks’ timeline, their appearance (color) 
remains the same.

You may move the events to different track timelines. In that case, the events appear as 
simple outlines and you will see their original tracks and positions. When you release the 
mouse, Vegas Pro automatically creates new tracks as needed for events.

4. Release the mouse to set the events’ timeline occurrences.

5. Repeat Steps 1-4 to move more events collectively along the timeline.

Ctrl Shift

Moving events along 
original tracks

Moving events to
different tracks
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Track navigation

Once an event is placed on a track, Vegas Pro automatically displays track controls that you 
can use to affect the event or events contained within the track. 

Track Number

This area identifies the track’s order number in a multitrack project. You may rearrange the 
track order by dragging and dropping selected tracks “up” or “down” within the Track List.

View buttons

These buttons control the track’s appearance (size) in the Track View.

Track Track 
Bus

Arm for 
Effects RecordView Mute Solonumber

Track color
Change the color
by right-clicking
and choosing
Track Color, and
then selecting the 
color you prefer.

Minimized

Normal

Maximized
CHP. 2 QUICK START



36
Track FX button

This button accesses Noise Gate, equalization (EQ), and compression FX controls that can 
be applied to the track’s event(s). For more information, see Adding track FX on page 130.

Bus assignment

This button allows you to designate and assign a track to a specific output bus. This option is 
available for projects being mixed for multiple stereo busses. (A bus is where various track 
signals are mixed together and output.) For more information, see Assigning a track to a bus on 
page 130.

Arm for Record button

This button allows you to prepare a track for recording. You may record directly into tracks. 
A track is ready when you see the recording meter appear on it. For more information, see 
Setting up to record into tracks on page 132.

Compression FXEqualization FXNoise Gate FX

Select a bus 
for playback
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Mute button

This button enables you to temporarily disable playback of the track, so you can focus on 
another track’s event(s). When a track is muted, it appears “grayed out” on the Track View. 
For more information, see Muting a track on page 129.

Solo button

This button, as its name implies, isolates a track’s events for playback, while muting the 
other tracks’ events. For more information, see Soloing a track on page 129.

Scribble Strip

This area lets you label a track. Simply double-click in the strip and type the track’s name. 
Or, right-click anywhere in the Track List and choose Rename from the shortcut menu and 
then type the track’s name. If you do not see the Scribble Strip, expand the track. For more 
information, see Changing track height on page 127.

Before muting the track After muting the track

Before applying Solo to the track After applying Solo to the track

Scribble Strip

Right-click
track to display
pop-up
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Volume fader

This fader controls the track’s loudness relative to the other tracks when it is played back. 
Vegas Pro tracks are preset at 0.0 decibel (dB). Use this fader to emphasize or de-emphasize a 
particular track. A track’s volume range is -inf. to 12 dB. 

To move the fader, do the following:

1. Place the mouse cursor on the fader.

2. Press and hold the left mouse button.

3. Move the fader left or right and release the mouse.

Note: You may also move the fader by 
clicking it and using the right or left arrow keys 
on the keyboard.

Multipurpose slider

If you do not see this slider, expand the track. This slider controls the track’s stereo panning 
and auxiliary bus volume. You may select what the slider controls by clicking its label. As 
you access the panning or auxiliary sends, Vegas Pro displays either its preset or your last 
setting preference. Each item’s slider position is independent from the others.

Double-click the slider
to reset to 0.0dB.

Click label
to view menu
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Panning

Vegas Pro tracks are preset to center the signal. Move the slider to adjust the signal’s output 
left or right. As you move the slider, Vegas Pro displays the signal’s percentage going to 
either the left or right channel. For example, moving the slider to 60%L means that 60 
percent of the signal is mixed to the left channel, while 40 percent is mixed to the right. For 
more information, see Adding a panning envelope on page 136.

 

Auxiliary bus

Vegas Pro projects that have multiple bus outputs enable you to send track signals to primary 
and secondary (auxiliary) busses. The primary bus is set using the Bus button on a track’s 
toolbar. For more information, see Bus assignment on page 36. The auxiliary bus enables you to 
send a signal to a separate bus independent of the primary bus. Auxiliary busses do not affect 
the project’s overall playback.

When you select an auxiliary bus, you need to adjust its playback volume with the slider. 
Auxiliary tracks’ volume are preset to -inf. dB (mute) for playback. For more information, see 
Assigning a track to an auxiliary bus on page 131.

FX send

If you add an FX Chain to a track, Vegas Pro adds that chain to the multi-purpose slider’s 
shortcut menu. You will be able to control the chain’s volume using this slider. 

Double-click the slider
to reset to Center.

Double-click the slider
to set its volume at 0.0 dB.
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Video event basics

Video events are placed on the Video Ruler. If the video event has audio, Vegas Pro creates 
an audio track and places the video’s audio on the “top” track in the track list. For more 
information, see Placing a event on the Video Ruler on page 32.

 

Once the event is in place, you may move the video event along the timeline, delete its 
audio, and preview the event in the Video Preview window. You may also replace the video 
by placing a new event on the Video Ruler. For more information, see Dragging/dropping or 
double-clicking a video event on page 32.

Moving the video event

Moving a video event is identical to moving an audio event. However, a video event is 
slightly different in that it may have audio grouped with it. If a video event has audio, Vegas 
Pro is preset to group the video event with its audio when it is placed. As a result, the video 
event and its audio will always be moved together along the project’s timeline. 

To move a video event, do the following:

1. Place the mouse pointer on either the video event or its audio.

2. Click and drag the events to the desired starting point on the timeline.

3. Release the mouse when the events are in the desired location.

Note: Ungroup a video and audio by right-
clicking either event. From the shortcut menu, 
choose Group, and then Clear. 

Video event with frame numbers

Video’s audio event

Video ruler
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Removing the video’s audio

As mentioned earlier, video events with audio get placed together in your project. However, 
you may delete the original audio completely or replace it with new audio. This feature is 
nice for redubbing poor quality audio.

To remove the audio, do the following:

1. Right-click either the video or its audio event to display a shortcut menu.

2. From the shortcut menu, choose Group, then Clear to ungroup the video and audio. 
Otherwise, both events will be remove.

3. Click to select the video’s audio event.

4. Right-click to display the shortcut menu. From the shortcut menu, choose Delete. 

Or, from the Edit menu, choose Delete.

Playing back the project

Vegas Pro allows you to play back your project in two ways: directly within Vegas Pro, or by 
mixing the entire project to a preview file. 

Play back within Vegas Pro

Vegas Pro has a Transport bar that allows you to play back your entire project or portions of 
your project based on a either a time selection or current cursor position. Only non-muted 
tracks and events are played back.

Before After

The video
remains on
the video
ruler.

Record

Loop Play from

Pause

Stop

Cursor 

Cursor 

Skip cursor

Skip cursor 

Play from 

play

start to start backward 

forwardto endcursor pos.
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If your project includes video, make sure the Video Preview window is displayed for 
playback: from the View menu, choose Video Preview or press the  keys.

Play back entire project

1. Press the  button to position the cursor at the beginning of the project.

2. Press the  button to start playback. 

Or, press the  button to begin playback at the beginning of the project.

3. Press the  button to stop playback.

Play back a time selection

1. Place the mouse pointer above the ruler (on the Marker bar). The mouse arrow includes a 
left/right arrow ( ). 

2. Click and drag to select the time region. To increase or decrease the time selection, click 
and drag its start and end points.

3. Press the  button to begin playback. Only the non-muted tracks and events within the 
time selection will play back.

4. Press the  button to have Vegas Pro continually play back the events within the time 
selection.

5. Press the  button to stop playback.

Playback reference

The following table describes all the playback buttons and keyboard equivalents. You may 
use these playback functions at any time while working in your project.

Button Keyboard Function
Begin recording into record-enabled tracks

Turn on/off loop play during time selection playback

 +  + Begin playback from the start of the project

Begin playback from cursor position

Pause playback, cursor stops and holds at pause position

 or Stop playback, cursor stops and returns to prior cursor position

 + Place cursor at the beginning of project

 + Place cursor at the end of the project

Moves the cursor to the left in grid increments (if grid is displayed)

Move the cursor to the right in grid increments

Alt + 6

Ctrl + R

L

Ctrl Shift Space

Space

Enter

Space Esc

Ctrl Home

Ctrl End

Page Up

Page Down
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Previewing to media player

A preview file is mixed according to the project’s properties that you set and is played back 
using the media player associated with the file type.

Mixing project for preview

This feature mixes all non-muted events to a file and automatically plays it back on the 
associated media player. 

1. From the Tools menu, choose Mix to Preview. The Preview dialog appears.

2. Select the preview option from the drop-down list.

3. Click the OK button to begin the mixing process. A status bar appears in the lower left 
portion of Vegas Pro.

Note: You may cancel the Mix to Preview by 
clicking the  button on the status bar.

When mixing is completed, the associated media player appears and begins playback. 

Working with project properties

You can view and set the project’s properties by choosing Properties from the File menu. The 
Properties dialog appears. 

Cancel
button

Status bar

General project 

Audio output 

Video output 

Ruler display 
settings

settings

settings

information
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Saving the project

The first time a project is saved you will select a Vegas Pro format to use. The format that 
you choose affects the project’s file size and its portability. There are two formats from which 
to choose:

To save the project, do the following:

1. Select one of the save methods:

• From the File menu, choose Save.
• Click on the  button. 
• Press  on the keyboard.

The first time you save a project, the Save As dialog appears. Skip to step 2.

The subsequent times you save, the above dialog is bypassed, your existing file name is 
retained, and your project is updated to include any implemented changes.

2. Select the drive and directory where you want to store the project.

3. Type the project name in the File Name field.

4. In the Save as type box, select the format for which you want to save the project (as 
described in the previous table).

5. Click the Save button.

Format Name Extension Definition
Vegas Pro Project *.veg Saves all of the information about a single project. This file format does not contain any 

media. It saves the references to media files used in the project. Also saved is project 
information, track FX, envelopes, bus assignments, and output properties. 

Vegas Pro Project with 
External Media

*.veg All of the media that is being used in the project is copied into the same folder as the 
project file. This option makes transporting the project easy and convenient.

Ctrl + S
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Renaming or rendering a project (using Save As...)

After you have been working with your project, you may use the Save As command in the 
File menu to rename the project. This option also allows you to render the project to a 
different file format. Typically rendering to a different format means that the project is 
finished and ready for distribution. 

Renaming a Vegas Pro project

You may use Save As from the File menu to save the project the first time. The only 
difference from the previous procedure is that the Save As dialog includes other file formats.

To rename a Vegas Pro project, do the following:

1. From the File menu, choose Save As. The Save As dialog appears. 

2. Select the drive and directory where you want to store the project.

3. Type a new name in the File Name field.

4. In the Save as Type drop-down list, select Vegas Pro Project (*.veg).

 

5.  Click the Save button.

If you want to copy
all the project’s media
into the same folder 
as the Vegas Pro file, select
this check box.
CHP. 2 QUICK START



46
Rendering a Vegas project

Rendering refers to the process of converting the Vegas Pro project into one file and 
formatting it for the desired playback method: media player, Internet streaming media, CD-
ROM, etc. The project file is not affected (overwritten, deleted, or altered) during the 
rendering process. You may return to the original project to make edits or adjustments and 
render it again. The following table describes the formats available for rendering your Vegas 
Pro project:

To render a Vegas Pro project, do the following:

1. From the File menu, choose Save As. The Save As dialog appears. 

2. Select the drive and directory where you want to save the rendered project.

3. Type a new name in the File name field, if necessary.

4. In the Save as type drop-down list, select the desired file format for rendering.

Format Name Extension Definition
Windows Media Format *.asf The Microsoft standard used for streaming media via the Web.
Wave (Microsoft) *.wav The standard audio file format used for audio used on Windows-based 

computers. 
Video for Windows *.avi The standard video file format used on Windows-based computers. This 

option renders both audio and video into one file.
Audio Interchange File Format *.aif The standard audio file format for audio used on Macintosh computers. 
RealSystem G2 *.rm The RealNetworks standard for streaming media via the Web. This option 

renders both audio and video into one file.
Windows Media Audio *.wma The Microsoft audio-only format used to create files for streaming or 

downloading via the Web.
Vegas Pro project *.veg This option saves the references to media files used in the project. Also saved 

is project information, track FX, envelopes, bus assignments, and output 
properties. The *.veg file does not combine events into a single file. 

Vegas Pro EDL *.txt This option creates a text version of event placements in the Track View. This 
text description can then be imported into a database or text application for 
modification or other purposes.
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5. Select any applicable check boxes, if necessary.

6. Click the Save button. A status bar appears in the lower left portion of Vegas Pro. Upon 
completion of the render, your Vegas Pro project is ready for distribution and playback.

Note: You may cancel the rendering process 
by clicking the  button on the status bar.

Copy all media with 
project

Used with Vegas Pro (*.veg) projects only. This option takes all of the media that is referenced in 
the project and copies it to the same folder to which you are saving the project.

Render entire project If you have a time selection in your project, select this option to ensure that the entire length of the 
project is rendered. If you do not select this option, only the time selection in the project will be 
rendered. 

Save project markers 
in media file

If your project contains defined markers or regions, you may save that information in the rendered 
file. Saving markers into a media file can enhance the end user’s interaction with the media file.

Select a rendering format

The check box options in the lower left of the Save As dialog
are available depending on the rendering format that you chose.
(They are all shown available here for display purposes only).

Cancel
button

Status bar
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Tutorial
Welcome to the Vegas Pro tutorial. It is designed to familiarize you with the basic features 
and tools of Vegas Pro while creating a project. The following sections are primarily step 
oriented and less descriptive, although descriptions are given. If you would like to learn 
more about a particular topic in the tutorial, access the online help. For more information, see 
Accessing help on page 15. 

This tutorial will teach you how to place media files in the project, edit them, and save them 
together into a video file. We provide you with the files you need to create this sample 
project. 

We will take a video that has poor audio quality and replace its audio with a voice-over 
recorded in a studio. The new audio will need to be synchronized with the video. The voice-
over will also require some editing and equalization. In addition, the video has theme music 
that we are going to replace with a new music bed. 

The video length is approximately 15 seconds. As you work, you will see how easy it is to 
master the powerful features that Vegas Pro has to offer. 

If you make a mistake during the tutorial, just undo it by pressing . 

Let’s get started!

Getting the tutorial folder

First, we need to get the sample media files copied to your hard drive. The tutorial folder is 
located on the Vegas Pro CD-ROM. 

1. Insert the CD-ROM into the disc drive.

2. Locate the Tutorial folder on the CD-ROM and copy it to your hard drive.

3. After the folder is copied, start Vegas Pro.

Ctrl + Z
TUTORIAL
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Using the Explorer window

The Explorer window allows you to view and access your media files without leaving the 
work area. This window works just like the Explorer you use with Microsoft Windows.

1. Locate the Tutorial folder on your hard drive.

2. Select the Tutorial folder so that its contents appear in the media list.

Once a media file is placed into the project, it is referred to as an event. 

Placing the video

In the media list you will see several files; we are going to place the Tutorial file ( ).

1. Press  to place the cursor at the beginning of the project.

2. Select the Tutorial file in the media list.

3. Place it by double-clicking on it. This will place the video on the Video Ruler and the 
audio on the first track at the cursor’s position.

Media
list

Ctrl + Home

Video Ruler

Audio track
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Displaying the Video Preview

We need to display the Video Preview window and move it to the Docking Area. This way 
we can watch the video as it is played back.

1. From the View menu, choose Video Preview. The Video Preview window appears.

2. Place the mouse pointer on the Video Preview’s title bar and drag it to the lower right 
portion of the work area (over the Mixer window).

 

3. When the Video Preview’s title bar disappears, release the mouse. The Video Preview 
window docks into position below the Track View.
CHP. 3 TUTORIAL
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Play back the video

During playback, you will see and hear a number of elements: an opening and closing 
graphic with a music sound track, and background noise recorded along with our narrator. 

1. Press the  button on the Transport bar to start playback. Playback begins at the current 
cursor position. So, if playback starts in the middle of the project, press the  button to 
start playback from the beginning.

2. Press the  button to stop playback.

3. Press the audio track’s  button to mute the video’s audio track. 

 

We are preparing to place and work with the new voice-over. Eventually, we will delete 
the original audio, but for now let’s use it as a reference point.

Placing the new voice-over

The new voice-over will replace the poor quality audio that is muted on the first track. 

1. In the media list, select the file titled Voiceover.

2. Drag the file so that its starting point is approximately when our narrator appears on the 
timeline. Drop the file, and Vegas Pro creates a new track for it.

3. Press either the  or  button to play the voice-over.

4. Press the  button to stop playback.

During playback, you will hear the narrator’s pause to review notes and cough. Below is the 
“anatomy” of the voice-over.

These errors (B and D) will be removed later. Also, during playback you probably saw that 
the new voice-over and the video are out of sync. Next, we will align the voice-over with 
the video.

Transport bar

Track mute

A B C D E A-
B-
C-
D-
E-

Welcome to Sonic Foundry...

Um...

This tutorial will...

[Cough]

Found in the new...
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Aligning new voice-over with video

We will now position the voice-over so that it will be synchronized with the video. We will 
use the poor quality audio as a reference point. Since we can see the audio waveform, 
sychronizing is made easier. You can also refer to the video’s frames on the ruler to see when 
the narrator begins to appear in the video.

To make it easier to see the audio events, we can zoom in on the project. There are a several 
ways to manage the project’s view. For more information, see Changing track height on page 127.

1. Press  so the Track View takes focus of keyboard commands.

Or, click in the Track View.

2. Press and hold the  keys.

3. Press either the  or  keys. You will toggle through different Track heights. 

4. Click and drag the new voice-over’s starting point to approximately when the narrator 
begins to speak. The original audio waveform, although distorted, reveals the narrator’s 
voice.

5. On the timeline, click and drag the mouse to select a time region.

Alt + 0

Ctrl + Shift 

Original audio

Voice-over

Selection bar
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6. Press the  or  button to play just the time selection. Press the  button, on the 
Transport bar, to have playback loop continuously within the selection.

7. Watch the Video Preview window to see if the new voice-over is close. 

8. Press the  button to stop playback.

9. Repeat steps 3-7 until you have the starting points of the voice-over and the video 
synchronized. 

Next we will edit the “ums” from the voice-over and synchronize the remaining voice-over 
with the video.

Editing the voice-over

When you played back the new voice-over, you noticed the interruption errors that it 
contained. We will remove those errors and synchronize the remaining voice-over to the 
video. Vegas Pro allows you to edit both time and events. We will use both methods to edit 
the voice-over. In addition, we will split an event to “separate” it from the parts we want to 
keep.

Lock the original audio

Time selection edits affect all tracks in the project unless a specific Track is selected. Before 
we start editing the voice-over, we will lock the original audio, which is our reference, to 
prevent it from accidently being edited too. 

1. Click the video’s original audio to select it.

2. From the Edit menu, choose Switches and then Lock. 
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Editing a time selection

By looking at the waveform, you will see where the “um” and cough occur. You will also see 
where the narrator is speaking. We will delete the “um” using time selection.

1. On the timeline, click and drag to make a time selection where the “um” occurs.

2. Press the  button to play back the error to ensure that your time selection does not 
include part of the voice-over that we need.

3. Increase or decrease the time selection by clicking and dragging an edge of the selection.

4. Once the time selection is made, choose Delete from the Edit menu, or press the  
key to remove the “um.”

Next, we will split the event that contains the narrator’s cough and then delete the error.

Splitting an event using time selection

Splitting creates events from an existing one. We will make a time selection that contains 
the narrator’s cough and split it from the audio, then delete the cough.

1. On the timeline, click and drag to make a time selection where the cough occurs.

2. Press the  button to play back the error to ensure that your time selection does not 
include part of the voice-over that we need.

3. Increase or decrease the time selection by clicking and dragging an edge of the selection. 
The start and end points will be the split points.

4. Once the time selection is made, choose Split from the Edit menu, or press the  key to 
split the event.

Delete

S

One event Three events
before the split after the split
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Editing an event

We have the cough as a new event that can now be deleted. 

1. Click the event with the cough.

2. From the Edit menu, choose Delete or press the  key to remove the cough event.

After the edits have been made, the voice-over should look something like this:

Aligning the remaining voice-over events

With the voice-over edited, we need to align the remaining audio to the video. When you 
move events, they snap to other event edges. You may extend or shorten an event’s length 
by clicking and dragging its edges, which is useful for fine-tuning the alignment. Moreover, 
you may turn off snapping by choosing Enable Snapping from the Options menu.

1. Select the event that begins “This tutorial will introduce you....”

2. Click and drag the event to the approximate point where our narrator is saying this. Use 
the original audio as a reference.

3. On the timeline, click and drag the mouse to select a time region.

4. Press the  or  button to play just the time selection. Press the  button, on the 
Transport bar, to have playback loop continuously within the selection.

5. Watch the Video Preview window to see if the new voice-over is close. 

6. Press the  button to stop playback.

7. Repeat steps 2-6 until you have the voice-over and the video synchronized. 

8. Repeat the above steps for the event that begins “found in this new....”

Next, we will group the synchronized events with the video and delete the original audio 
from the project.

Delete

"Welcome to Sonic
Foundry Vegas.

This tutorial will introduce
you to the powerful editing
and post-production features...

...found in this 

environment.”
new production
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Grouping the voice-over and video

The voice-over and video are synchronized, and we want to make sure that they stay 
together. The Grouping feature will do that for us. However, first, we will delete the original 
audio.

1. Select the original audio’s track by clicking it.

2. Right-click and choose Delete from the shortcut menu. The entire track is removed from 
the project and the new voice-over becomes the first track.

3. Press the  key and click the video event and the three voice-over events to select 
them.

4. From the Edit menu, choose Group and then Create New or press the  key. to group the 
events. 

Next, we will place a new audio file to serve as a music bed for the video and add a 
volume envelope.

Working with the music bed

We will place an event that will play for the entire video. We will add a volume envelope to 
lower the volume while the narrator speaks, and then increase the volume again for the 
remainder of the video.

Placing the music bed

1. Press the  key to move the cursor to the beginning of the project.

2. In the media list, double-click the Music bed file to place it at the beginning of the 
project.

3. Press the  button to play the project. 

Ctrl

G

Ctrl + Home
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Adding a volume envelope

The music bed’s volume needs to be lowered while the narrator speaks. A volume envelope 
will automatically lower the volume, and then raise it again when the narrator finishes 
speaking. We will use the voice-over’s starting and ending points as a reference for the 
envelope.

1. Select the music bed track or event.

2. From the Insert menu, choose Audio Envelopes and then choose Volume. A blue line 
appears across the track.

3. On the music bed, place the mouse pointer slightly ahead of the voice-over’s starting 
point. The mouse pointer appears as a hand ( ).

4. Right-click and choose Add Point from the shortcut menu. A square point appears on the 
envelope line.

5. Repeat step 4 to add three more points on the line. You want a total of four points.

Setting the volume envelope

Now we will use the points on the envelope to lower and raise the volume so that the music 
bed does not interfere with the voice-over. When you click or hover over a point, 
information about it appears.

1. Click and drag the points so that they are positioned with two near the start of the voice-
over, and two at the end.

Envelope Line
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2. Click and drag the two inner points so that their volume level is at approximately -7.0 dB.

3. Set the outer points so that their volume level is at 0.0 dB.

4. Press either  or  to play the project and check the timing of the volume envelope.

5. Adjust the outer and inner points along the timeline as needed.

Next, we will add some equalization to the voice-over.

Add EQ to the voice-over

The voice-over has a strong bass quality to it. We will adjust that quality slightly with EQ on 
the first band.

1. Click the  button on the voice-over’s track. The Track FX dialog appears. 

You can set the EQ settings by typing in the appropriate field, dragging the slider, or clicking 
the arrow buttons between the slider and the setting field.

2. Set the Frequency to 160 Hz.

3. Set the Gain to -inf.

4. Set the Rolloff to 12 (dB/oct).

5. Close the Track FX dialog by clicking anywhere outside it.

6. Press either  or  to play the project with the new EQ settings.

Next, we will save the project as a Vegas project file.

You can only set one point
at a time or use the Envelope
tool to select and move
multiple points at a time.
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Saving a Vegas project (*.veg)

A Vegas project file contains all of the information about a single project. However, it does 
not contain any media, but maintains the references to media files used in the project. 

1. Select one of the following to save the Vegas Pro project:

• From the File menu, choose Save.
• Click on the  button. 
• Press  on the keyboard.

The first time you save a project, the Save As dialog appears.

2. Select the drive and directory where you want to store the project.

3. Type the project name “MyTutorial” in the File Name field.

4. Click the Save button.

The subsequent times you save the project, the above Save As dialog is bypassed, your 
existing file name is retained, and your project is updated to include any implemented 
changes.

Ctrl + S
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Rendering the project as an *.avi

Rendering refers to the process of converting the Vegas project into one file and formatting 
if for the desired playback method: media player, Internet streaming media, CD-ROM, etc. 
The Vegas project is not affected (overwritten, deleted, or altered) during the rendering 
process. 

The following procedure is broken into two sections: setting the format and applying 
compression.

Setting the format

1. From the File menu, choose Save As. The Save As dialog appears. 

2. Select the drive and directory where you want to save the rendered project.

3. Type a new name in the File name field, if necessary.

4. In the Save as type drop-down list, select Video for Windows (*.avi).
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Applying compression

To ensure that the video plays back in sync, we will set compression values.

1. On the Save As dialog, click the Custom button. The Custom Settings dialog appears.

2. Click the Video tab, then click the Compression button. The Video Compression dialog 
appears.

3. Set the compression to the following settings.

• From the Compressor drop-down list, choose Cinepak 
Codec by Radius.

• Set the key frame rate to 7 frames.
• Set the data rate to 125 KB/sec.

4. Click the OK button to set the video compression.

5. Click the OK button on the Custom Settings dialog.

6. Click the Save button on the Save As dialog. A status bar appears in the lower-left 
portion of Vegas Pro. Upon completion of the render, your new media file is ready for 
distribution and playback.

Note: You may cancel the rendering process 
by clicking the  button on the status bar.

Congratulations! You have just completed your first project using Vegas Pro.

Cancel
button

Status bar
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General Editing
Vegas Pro projects are multitrack compilations of events that occur over time. The events in 
your project are references to source media files on your hard-drive or other storage device. 
Vegas Pro is a non-destructive editor, so the audio events in your project will always contain 
their referenced information. As a result, editing events in Vegas Pro is as simple as adjusting 
the events’ edges (in/out points), placing, and moving the events along the timeline.

The following chapter explains general editing techniques and features that apply to a 
project as a whole. 

Using the cursor

When editing and playing back the project, the cursor identifies where you are along the 
project’s timeline. The cursor can also be used when placing events in the project. For more 
information, see Placing a media file on a track on page 31.

By clicking and dragging you may select a time range in which you can preform edits, record 
into, and play back. For more information, see Selecting a time range on page 65.

The cursor may be controlled by the mouse or keyboard commands.

Go to beginning of selection 
or view (if no selection)

Home or W Center in View \

Go to end of selection or view 
(if no selection)

End or E Swap on selection Num. pad 5

Go to beginning of project Ctrl+Home Move left to marker(s) Ctrl+Left (arrow)

Go to end of project Ctrl+End Move right to marker(s) Ctrl+Right (arrow)

Move left by grid marks Page Up Move left to event edit points 
including fade edges

Ctrl+Alt+Left 
(arrow)

Move right by grid marks Page Down Move right to event edit points 
including fade edges

Ctrl+Alt+Right

Go to Ctrl+G Make time selection Shift+Left or Right 
(arrow)
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Editing event and time selections

Vegas Pro gives you the flexibility to select one or more events, a time range, or events and 
time range. All selection options can apply to a single track or multiple tracks.

To select an event, simply point and click on it.

Selecting multiple events

By using the  key, the  key, or the Selection Edit tool ( ), you may select 
individual or multiple events in your project. Multiple events may be selected within a track 
or across tracks. Once events are selected, you may apply any of the Edit menu commands or 
editing shortcut keys to them collectively.

Whichever method you choose, you may include or exclude events from a selection area by 
holding down the  key and clicking on an event.

Using the Ctrl key to select an event

The  key allows you to select events manually.

1. Hold down the  key.

2. Select the events by clicking on them. To deselect an event, simply click it again (this is 
called “toggling” the event selection on or off). 

Using the Shift key to select events

The  key on your keyboard allows you to select project events sequentially.

1. Hold down the  key.

2. Click the first event that you want to select. 

3. Click the last event that you want to select. All events between the first and last selected 
events are highlighted.

Selected Non-selected 
eventevent

Ctrl Shift

Ctrl

Ctrl

Ctrl

Shift

Shift
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Using the Selection Edit tool

The Selection Edit tool ( ) allows you to select events as a block.

1. On the Toolbar, click the  button.

2. Point the cursor in a corner of the area that you want to select.

3. Press and hold the left mouse button.

4. Drag the cursor to the opposite corner of the area you want to select.

5. Release the mouse button. The events are highlighted.

Note: While using the  button, you may 
toggle through 3 selection modes by right-
clicking.

Selecting a time range

Vegas Pro has a time selection bar that is located above the ruler. This bar displays, with a 
shaded box, the time range that you have selected. You may use the time selection bar for 
playing back a smaller portion of your project or to apply cross-track edits.

Unless an event is locked, a selected time range affects all events, or portions of events, that 
occur within the range. If you are editing the time range, only events that occur within the 
time range will be affected.

To select a time range, do the following:

1. Place the mouse pointer above the ruler (on the Marker bar). The mouse pointer includes 
a left/right arrow ( ). 

2. Click and drag to select the region. All events, or portions of events within the region are 
highlighted.

Time selection bar

Only the events within 
the time selection will be
affected by edits or be
played back.
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3. Place the mouse pointer over the time selection’s start or end point to increase or decrease 
your time range selection.

Note: You may move the entire selection 
range by dragging the Time selection bar.

If you want to play back the time range, press the Play button ( ) to listen to only the 
events within the time range. Press the Loop button ( ) to have Vegas Pro continually play 
back the events within the time selection.

Selecting events and a time range

Selecting a time range does not automatically select events. It simply selects a time frame of 
the project. Excluding locked events, all items within the time range will play back and be 
affected by Edit menu commands such as cutting, pasting, etc. However, you may select 
specific events to edit or play back, and then select a time range. 

1.  Use the  key, the  key, or the Selection Edit tool  to select the events. For 
more information, see Selecting multiple events on page 64.

2. Place the mouse pointer above the ruler (on the Marker bar). The mouse pointer includes 
a left/right arrow ( ). 

3. Click and drag to select the region. Notice that events that were not selected remain 
unselected (not highlighted).

4. Place the mouse pointer over the time selection’s start or end point to increase or decrease 
your time range selection. 

Basic event editing

Vegas Pro allows you to perform simple event level editing. This editing includes common 
copying, pasting, and deleting procedures that you are accustom to with other programs. 
However, these editing procedures and how they are implemented depend on what type of 
selection is made: event only, time only, or event and time selections.

Ctrl Shift

Non-selected eventSelected event

Selected event

Selected eventNon-selected event
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Copying events

Vegas Pro allows you to copy events, or portions of events, to the clipboard and paste them 
into your project. You may copy a single event or multiple events. Copying preserves the 
original event information that is being copied.

To copy events, do the following:

1.  Click on the event.

To copy multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple events on page 64.

2. Select your time range, if applicable. Otherwise, skip to step 3.

3. Copy the event to the clipboard by doing one of the following:

• Press the  keys.
• Click the Copy button  on the Toolbar. 
• From the Edit menu, choose Copy.

Copy time selection

Events within the time selection are reproduced and placed on the clipboard. Also, the time 
information is placed on the clipboard.

Copy time and event selection

Events and portions of events within the time selection are reproduced and placed on the 
clipboard. Also, the time information is placed on the clipboard.

Events before copy Clipboard contents Events after copy
The original events are not 
affected and do not 
change.

Events before copy Clipboard contents Events after copy
The original events are not 
affected and do not 
change.

Ctrl Shift

Ctrl + C
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Copy event selection

Selected events are reproduced and placed on the clipboard. Also, the time information is 
placed on the clipboard.

Pasting events

Once information is copied to the clipboard, you may choose a variety of ways to paste the 
clipboard items into tracks. The following procedures explain pasting basics. Whichever way 
you paste into a track, Vegas Pro always pastes at the cursor’s position along the timeline.

To paste events from the clipboard, do the following:

1. Move the cursor to the desired timeline location.

2. Click either the track number or within the track where you want to paste the event.

 

If you are pasting multiple events from different tracks, Vegas Pro automatically creates 
new tracks as needed for events, or simply places events in existing tracks.

3. Paste the event into the track by doing one of the following:

• Press the  keys.
• Click the Paste button  on the Toolbar.
• From the Edit menu, choose Paste.

Clipboard events are pasted at the cursor position on the track. 
Existing track events are overlapped with newly-pasted information.

Events before copy Clipboard contents Events after copy
The original events are not 
affected and do not 
change.

Clipboard contents Events before paste Events after paste

Click either to select the track

Ctrl + V

Paste
position 
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Paste repeat (Ctrl+B)

You specify how many times the clipboard events are pasted at the cursor position on the 
selected track and specify the space between each pasted event. 

After you have made your selection and copied it to the clipboard, do one of the following:

• Press the  keys.
• From the Edit menu, choose Paste Repeat.

 

Vegas Pro displays the Paste Repeat dialog. Specify the number of times to paste the 
clipboard events and their space from each other.

Press the OK button to paste the clipboard events the number of times you specified. 
Vegas Pro begins pasting from the cursor’s position along the timeline. The clipboard 
contents are pasted one after another unless you have specified a paste spacing. In that 
case, a space will appear between each pasted event.

Ctrl + B
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Paste insert (Ctrl+Shift+V)

Clipboard events are placed at the cursor position on the selected track. Existing events on a 
track are moved later in the timeline by the total length of pasted information.

After you have made your selection and copied it to the clipboard, do one of the following:

• Press the  keys.
• From the Edit menu, choose Paste Insert.

Cutting events

Vegas Pro allows you to cut events, portions of events, and any time information from your 
project. Cutting events removes them from their respective tracks, but places the cut 
information (events and time) on the clipboard. Once on the clipboard, you may paste the 
information into your project. You may cut a single event, multiple events, and events with 
a time selection.

To cut events, do the following:

1. Click on the event to be cut.

To cut multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple events on page 64.

Clipboard contents Events before paste Events after paste

Ctrl + Shift + V

Ctrl Shift
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2. Select your time range, if applicable. Otherwise, skip to step 3. 

3. Cut the event to the clipboard by doing one of the following:

• Press the  keys.
• Click the Cut button  on the Toolbar. 
• From the Edit menu, choose Cut.

Cut time selection

Events within the time selection are reproduced and placed on the clipboard. Also, the time 
information is placed on the clipboard. 

Cut time and event selection

Events and portions of events within the time selection are reproduced and placed on the 
clipboard. Also, the time information is placed on the clipboard.

Cut event selection

Selected events are reproduced and placed on the clipboard. Also, the time information is 
placed on the clipboard.

Events before cut Clipboard contents Events after cut

Events before cut Clipboard contents Events after cut

Events before cut Clipboard contents Events after cut

Ctrl + X
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Trimming/Cropping events

Vegas Pro allows you to trim/crop events, or portions of events, from your project. Trimming 
events removes all events outside the time selection from their respective tracks. However, 
the removed information is not placed on the clipboard. Trimming is different from cutting 
in that the events within the time selection are preserved.

To crop events, do the following:

1. Click on the event to be trimmed, if applicable. Otherwise, skip to Step 2.

To trim multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple events on page 64.

2. Select your time range.

3. Trim the event(s) by doing one of the following:

• Press the  keys.
• From the Edit menu, choose Trim/Crop.

Trim/Crop time selection

Events outside the time selection are removed from the project. However, the time 
information is not removed.

Events before trim Clipboard contents Events after trim
Trimmed information is not 
placed on the clipboard.

Ctrl Shift

Ctrl + T
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Trim/Crop time and event selection

Only selected events outside the time selection are removed from the project. Non-selected 
events remain. The time information is not removed. 

Deleting events

Vegas Pro allows you to delete events, or portions of events, from your project. Deleting 
events removes all events within the time selection from their respective tracks. However, 
the removed information is not placed on the clipboard.

To delete events, do the following:

1. Click on the event to be deleted.

To delete multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple events on page 64.

2. Select your time range, if applicable. Otherwise, skip to step 3.

3. Delete the event(s) by doing one of the following:

• Press the  key.
• From the Edit menu, choose Delete.

Delete time selection

Events within the time selection are removed from the project. 
However, the time information within the selection is not removed. 

Events before trim Clipboard contents Events after trim
Trimmed information is not 
placed on the clipboard.

Events before delete Clipboard contents Events after delete
Deleted information is not 
placed on the clipboard.

Ctrl Shift

Delete
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Delete time and event selection

Only selected events within the time selection are removed from the project. Non-selected 
events remain.The time information within the selection is not removed.

Delete event selection

Selected events are removed from the project. The time information between events is not 
removed.

Using the Undo and Redo commands

Vegas Pro gives you unlimited undo and redo functionality while working on your project. 
While you are working with a project, Vegas Pro creates an undo history of the edits that you 
performed. Each time you undo something, that edit is placed in the redo history. These 
histories remain available as you save the project. However, if a redo history exists (you’ve 
undone an edit) and you perform another edit, the redo history is cleared. 

When you close the project or exit Vegas Pro, both the undo and redo histories are cleared. 

Undo command

Pressing the  keys or Undo ( ) button on the Toolbar will undo the last edit 
performed. Repeatedly using the keyboard command or Toolbar button will continue 
undoing edits in reverse order. Moreover, you may undo the last edit by choosing it from the 
Edit menu (it will be the first item on the menu).

Events before delete Clipboard contents Events after delete
Deleted information is not 
placed on the clipboard.

Events before delete Clipboard contents Events after delete
Deleted information is not 
placed on the clipboard.

Ctrl + Z

Undo last edit
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Undoing a series of edits

The undo history may be viewed by clicking the down arrow to the right of the  button 
on the Toolbar. A drop-down list will appear (a scroll bar also appears if numerous undos are 
listed). The top listed item is the most recent edit. If you want to undo a specific edit that 
appears farther down the list, all edits “above” it must be undone as well. 

To undo a series of edits, do the following:

1. Click on the arrow to the right of the  button.

2. From the drop-down list, use the scroll bar to locate the last series item to undo.

3. Place the mouse pointer on the item that you want to undo. Items “above” it will be 
selected automatically. (Click outside the drop-down list to cancel undo.)

4. Click the last series item to undo it and all selected edits. Vegas Pro will restore your 
project to the state prior to those edits.

When you undo an edit or a series of edits, they are added to the redo history. This feature 
allows you to restore your project to a specific state.

Note: You may also undo all edits by choosing 
Undo All from the Edit menu. All edits will be 
undone and added to the redo history.

Scroll bar

Hover the mouse
pointer and drag
it down to select
a series of edits.
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Redo command

Pressing the  keys or the Redo ( ) button on the Toolbar will redo the last 
undo performed. Repeatedly using the keyboard command or Toolbar button will continue 
redoing undos in reverse order. In addition, you may redo the last edit by choosing it from 
the Edit menu (it will be the second item on the menu).

Redoing a series of edits

The redo history may be viewed by clicking the down arrow to the right of the  button on 
the Toolbar. A drop-down list will appear (a scroll bar also appears if numerous redos are 
listed). The top listed item is the most recent undo edit. If you want to redo a specific edit 
that appears farther down the list, all edits “above” it must be redone as well. 

To redo a series of edits, do the following:

1. Click on the arrow to the right of the  button.

2. From the drop-down list, use the scroll bar to locate the last series item to redo.

3. Place the mouse pointer on the item that you want to redo. Items “above” it will be 
selected automatically. (Click outside the drop-down list to cancel redo.)

4. Click the last series item to redo it and all selected edits. Vegas Pro will restore your 
project to the state to include those edits.

When you redo an edit or a series of edits, they are added to the undo history again. At this 
point, the redo history is cleared when a new edit is performed.

Ctrl + Shift + Z

Redo last edit

Scroll bar

Hover the mouse
pointer and drag
it down to select
a series of edits.
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Clearing the edit history

You may clear both undo and redo histories without closing your project or exiting Vegas 
Pro. Once the histories have been cleared, Vegas Pro will begin creating new ones as you 
continue working on the project.

To clear the edit histories, do the following:

1. From the Edit menu, choose Clear Edit History. A confirmation dialog will appear.

2. Click the Yes button to clear the edit histories. Or, click the No button to cancel and 
keep the edit histories.

Using project markers and regions

Vegas Pro allows you to use three types of project markers that identify parts of your project 
and provide functionality for rendered projects. The three types of markers are:

• Markers–points that you place along the project’s timeline. They are typically used to 
mark interesting parts in the project for later reference.

• Regions–sets that subdivide your project. Typically, regions identify ranges of time that 
you need to get back to later. Regions can function as “permanent” time selections.

• Command markers–indicate when an instruction (function) will occur in a streaming 
media files. These markers can be used to display headlines, captions, link to web sites, or 
any other function you define.

Working with markers

Markers are useful for identifying and navigating to specific points in longer projects. As you 
place markers in your project, Vegas Pro automatically numbers them in the order that they 
were placed. You may name them and move them along the project’s timeline. 

Placing and moving a marker

Markers are placed at the cursor’s position via the Insert menu, right-clicking on the Marker 
bar, or pressing the  key. You may place a marker by positioning the cursor or on-the-fly 
while your project is playing back. Markers appear as red tags above the ruler.

M
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To move a marker, do the following:

1. Place the mouse pointer on the marker you want to move. The pointer will appear as a 
hand ( ).

2. Click and drag the marker to the new position along the timeline.

3. Release the mouse to set the marker.

4. Repeat steps 1-3 to move the marker again.

Naming a marker

You may name each marker in your project by doing the following:

1. Place the mouse pointer on the marker you want to name or rename. The pointer will 
appear as a hand ( ).

2. Right-click to display a shortcut menu.

3. From the shortcut menu, choose Rename. A text box will appear next to the marker.

Marker

Marker bar

Right-click on Marker bar
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4. Type the marker name.

5.  Press the  key or click anywhere in the Track View to set the marker’s name. 

Navigating to a marker

You may have scrolled to a portion of the project and do not see the cursor any more. You 
may click in the Track View to move and view the cursor or you may use markers to bring 
the cursor into view.

To navigate using markers, do the following:

1. Place the mouse pointer on the marker that you want to position the cursor. The pointer 
will appear as a hand ( ).

2. Right-click to display a shortcut menu.

3. From the shortcut menu, choose Go to. The cursor’s yellow tags will appear below the 
marker tag. 

Note: You may also move the cursor to each 
marker by pressing the +  or  keys.

Enter

Ctrl
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Deleting a marker

You may remove markers from your project by doing the following:

1. Place the mouse pointer on the marker that you want to delete. The pointer will appear as 
a hand ( ).

2. Right-click to display a shortcut menu.

3. From the shortcut menu, choose Delete. The marker will be removed from your project. 

The marker numbers will remain the same, Vegas Pro will not renumber the tags as you 
remove them. For example, if you have five markers in your project and delete markers 3 and 
4, the remaining markers will be listed as 1, 2 and 5. However, as you add markers again, 
Vegas Pro will begin numbering the missing sequence first. In our example, if you add three 
more markers, they will be numbered 3, 4, and 6.

Working with regions

Regions are sets that subdivide your project. Typically, regions identify ranges of time that 
you need to get back to later. Regions can function as “permanent” time selections.

Placing and adjusting a region

Region markers may be placed at the cursor position and at the beginning and end points of 
a time selection via the Insert menu or pressing the  key. 

To adjust a region marker, do the following:

1. Place the mouse pointer on either the region’s start or end point. The pointer will appear 
as a hand ( ).

R

Region start

Marker bar

Region end
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2. Click and drag the marker to the new position along the timeline.

3. Release the mouse to set the region marker.

4. Repeat steps 1-3 to move either the region marker’s start or end point.

Naming a region marker

You may name a region marker’s start or end point by doing the following:

1. Place the mouse pointer on the region marker you want to name or rename. The pointer 
will appear as a hand ( ).

2. Right-click to display a shortcut menu.

3. From the shortcut menu, choose Rename. A text box will appear next to the region 
marker.

4. Type the regions marker’s name.

5.  Press the  key or click anywhere in the Track View to set the name.

Selecting a region

You may select the events, across all tracks, within the region to edit the events or to play 
back only the region. 

Enter
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To select the region, do the following:

1. Right-click on one of the region markers to display a shortcut menu.

2. From the shortcut menu, choose Select Region.

Note: You may double-clicking between the 
region marker tags on the Marker bar to select 
the region.

Navigating to a region

You may have scrolled to a portion of the project and do not see the cursor any more. You 
may click in the Track View to move and view the cursor or you may use region markers to 
bring the cursor into view.

To navigate using region markers, do the following:

1. Place the mouse pointer on any region marker that you want to position the cursor. The 
pointer will appear as a hand ( ).

2. Right-click to display a shortcut menu.

3. From the shortcut menu, choose Go to or Go to End. 

The difference is that Go to places the cursor at the region’s starting point and Go to End 
places it at the region’s ending point. The cursor’s yellow tags will appear below either the 
region’s starting or ending tag. 

Note: You may also move the cursor to each 
marker by pressing the +  or  keys.

Selected region

Ctrl
GENERAL EDITING CHP. 4



83
Deleting a region

You may remove a region from your project by doing the following:

1. Place the mouse pointer on either the region marker’s starting or ending point. The 
pointer will appear as a hand ( ).

2. Right-click to display a shortcut menu.

3. From the shortcut menu, choose Delete. The marker will be removed from your project. 

The region marker numbers will remain the same, Vegas Pro will not renumber the tags as 
you remove them. For example, if you have five regions in your project and delete region 3 
and 4, the remaining regions will be listed at 1, 2 and 5. However, as you add regions again, 
Vegas Pro will begin numbering the missing sequence first. In our example, if you add three 
more regions, they will be numbered 3, 4, and 6.

Working with command markers

Command markers indicate when an instruction (function) will occur in a streaming media 
file. These markers can be used to display headlines, captions, link to web sites, or any other 
function you define.

Vegas Pro enables you to place five types of command markers:

• URL command markers indicate when an instruction is sent to the user’s internet browser 
to change the content being displayed. With this command marker, you enter the URL 
that will display at a specific time during playback of your rendered project.

• Text command markers display text in the captioning area of the Windows Media Player 
located below the video display area. You enter the text that will display during playback.

• Caption command markers display text in a captioning window defined by an HTML 
layout file.

• Body command markers display text that you specify in a text window defined by an 
HTML layout file.

• Headline command markers display a headline text that you specify in a headline window 
defined by an HTML layout file.
CHP. 4 GENERAL EDITING



84
Placing a command marker

Command markers are placed at the cursor’s position via the Insert menu, right-clicking on 
the Command Ruler, or pressing the  key. You may place a command marker by 
positioning the cursor or on-the-fly while your project is playing back. Command markers 
appear as blue tags on the Command Ruler, which is above the Marker bar.

If you do not see the Command Ruler, choose Command Ruler from the View menu.

When you place command markers, the Command Properties dialog will appear (if the 
Command Ruler is not displayed, Vegas Pro will automatically make it visible).

Use this dialog to define your own command or select a command from the drop-down list. 
This dialog is also where you edit the behavior of the selected command markers.

• The Command drop-down list allows you to select the type of command to place.
• The Parameter field defines the behavior of the command.
• The Comments field is generally used to remind you of what the command is while you 

work on the project. (Its function is similar to naming markers and regions.) 
• The Position field allows you to specify when in the rendered file the command will occur. 

When you place a command marker, its time is automatically set to the current cursor 
position.

C
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Once the command properties are set, click the OK button to place the command marker 
on the Command Ruler.

Moving a command marker

To move a command marker, do the following:

1. Place the mouse pointer on the command marker you want to move. The pointer will 
appear as a hand ( ).

2. Click and drag the command marker to the new position along the timeline.

3. Release the mouse to set the command marker.

4. Repeat steps 1-3 to move the command marker again.

Marker bar

Command Ruler

Text command marker URL command marker

Right-click to place a command marker
from the Command Ruler
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Editing a command marker

You may change the command markers properties at any time by doing the following:

1. Place the mouse pointer on the command marker you want to edit. The pointer will 
appear as a hand ( ).

2. Right-click the marker to display a shortcut menu.

3. From the shortcut menu, choose Edit. The Command Properties dialog will appear. 

4. Change the command type, retype parameters or comments, or enter a new position 
along the timeline.

5. Click the OK button to assign the new properties to the command marker.

Or, click the Cancel button to keep the command marker’s original properties.

Naming a command marker

The name you give to a command marker will appear in the Comments field on the 
Command Properties dialog. You may name each command marker in your project by doing 
the following:

1. Place the mouse pointer on the command marker you want to name or rename. The 
pointer will appear as a hand ( ).

2. Right-click to display a shortcut menu.

3. From the shortcut menu, choose Rename. A text box will appear next to the command 
marker.

4. Type the command marker’s name.

5.  Press the  key or click anywhere in the Track View to set the marker’s name. Enter
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Navigating to a command marker

You may have scrolled to a portion of the project and do not see the cursor any more. You 
may click in the Track View to move and view the cursor or you may use command markers 
to bring the cursor into view.

To navigate using command markers, do the following:

1. Place the mouse pointer on the marker that you want to position the cursor. The pointer 
will appear as a hand ( ).

2. Right-click to display a shortcut menu.

3. From the shortcut menu, choose Go to. The cursor’s yellow tags will appear below the 
marker tag. 

Note: You may also move the cursor to each 
marker by pressing the +  or  keys.

Deleting a command marker

You may remove a command marker from your project by doing the following:

1. Place the mouse pointer on the command marker that you want to delete. The pointer 
will appear as a hand ( ).

2. Right-click to display a shortcut menu.

3. From the shortcut menu, choose Delete. The command marker will be removed from your 
project. 

Ctrl
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Using a sound editor program

Vegas Pro is a non-destructive editing environment, which means that all the events’ data in 
your project is maintained and available as necessary. Destructive edits may be done in a 
separate application such as Sonic Foundry’s Sound Forge® to modify an audio event’s 
referenced file. By setting up a separate sound editor, you can quickly access the program 
from Vegas Pro via the Tools menu or  shortcut keys.

Setting up the sound editor program

If you already had Sound Forge loaded on your computer when you installed Vegas Pro, the 
installation should have detected it and made it your sound editor program. However, if you 
do not have Sound Forge or want to specify a different sound editor, you may do so in the 
Preferences dialog. 

To set up the sound editor program, do the following:

1. From the Options menu, choose Preferences. The Preferences dialog will appear.

2. On the Preferences dialog, choose the Audio tab.

3. Click the Browse button. The Preferred Audio Editor dialog will appear.

Ctrl + E
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4. From this dialog, navigate to the application to use for editing audio events.

5. Select the application’s executable icon (*.exe) and click the dialog’s Open button to set 
the application as your sound editor.

The application’s path will be displayed in the Location of preferred audio editor field.

 Opening the sound editor from Vegas Pro

All events in your Vegas Pro project are actually references to media files on a storage device 
(hard drive). When you edit an event in a sound editor, you are editing the media file to 
which the event is referenced. Any changes you make and save in the sound editor, will be 
reflected in the Vegas Pro project event. 

To edit an event in the sound editor, do the following: 

1. Select the event to be edited. You need to select the entire event.

2. From the Tools menu, choose Open in Sound Editor or press the  shortcut keys.

 

Your selected sound editor application will open and the event’s referenced media file will 
appear in the application. Make the necessary changes and save the file in the sound editor. 
If you keep the media file’s name and location the same, its event will be updated 
immediately in your project. However, if you change the media file’s name or location, you 
will need to import the edited event into Vegas Pro.

Ctrl + E
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5

Advanced Audio 
Editing
Vegas Pro provides many tools for working with the events in your project. The events may 
be edited and controlled to create the desired playback interaction you want. The tools 
described in this chapter are designed to achieve better work flow and play back effects that 
are intuitive and easy to use. 

The following sections describe event-specific editing and techniques.

Snapping events

Vegas Pro is preset to “snap” an event’s edges to grid lines, markers, the cursor position, or 
time selection. As you move an event along the timeline, its edge will automatically align to 
designated snap points.

Using the event snap offset 

Each event in your project has a snap offset flag that can be moved along the length of the 
event. The flag is the white triangle that is located in the lower-left corner of each event in 
your project. This flag allows you to designate where in the event snapping will occur.

Snap points

Snap offset flag

The time display reflects
time within the event not
the project Ruler.
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To set the snap offset, do the following:

1. Place the mouse pointer on the snap offset triangle. The pointer turns into a hand ( ).

2. Click and drag the snap offset flag to the new position in the event. As the flag is moved, 
you will see a time display appear. This time display indicates where the snap offset flag 
occurs in time in the event. 

3. Release the mouse to set the snap offset flag.

Snapping to grid lines

Vegas Pro allows you to specify what type of grid you want to use in your project. The grid 
lines that appear can then be used as snapping points for events and markers.

Enabling/disabling snapping to grid

You may enable and disable grid snapping by choosing Snap to grid from the Options menu 
or by pressing the  keys. When the grid is disabled for snapping, it will still be visible 
for reference. However, unlike a snap-enabled grid, it will disappear when the lines get too 
close together when zooming the view.

Changing the grid type

Vegas Pro includes many grid types that you may apply to your project. From the Options 
menu, choose Grid Spacing and then the type of grid you want from the sub-menu.

Note: In some cases, the grid lines and the 
Ruler will not “match.” This is because they 
are two independent functions. 

Ctrl + F8
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Snapping to markers

Vegas Pro allows you place markers in your project. For more information, see Using project 
markers and regions on page 77.The marker (or region) lines that appear across all tracks can 
be used as snapping points for events, cursor, and time selections.

Enabling/disabling snapping to markers

You may enable and disable snapping to markers by choosing Snap to Markers from the 
Options menu or by pressing the  keys. When you disable snapping to markers, the 
the marker lines will not appear across the tracks. The events, however, will not snap to 
them.

Disable snapping

Vegas Pro allows you to snap events to project markers that you have placed and the grid 
lines that appear in the Track View. You may disable snapping to either markers, grid lines, 
or disable snapping altogether.

To disable/enable all snapping, you may click the Snap ( ) button on the Toolbar.

Or, you may toggle the snap commands located on the Options menu. When a command is 
enabled, you will see a check mark next to it. To disable a snap command, simply select its 
check marked command to disable it.

Note: If you disable all snapping, an event 
will still snap to the cursor or region in/out 
points.

Shift + F8

All enabled

Select to disable/enable all snapping

Select to disable/enable only 

Select to disable/enable only 
snapping to placed markers.

snapping to grid lines.
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Splitting events

Vegas Pro allows you to create multiple, independently-functioning events from a single 
event by splitting them. Splitting creates a new ending point for the original event and 
creates a starting point for the newly-created event. 

Splitting an event does not delete or cut any information from the original event. The 
original event’s information is there, but omitted for playback based on where either the 
event’s starting or ending point occurs on the timeline. 

Also, when you split an event, the events abut each other so playback is unaffected on the 
timeline unless you move either of the abutting events or adjust their staring/ending points.

You may split single selected events, multiple selected events, or a time range of events.

To split an event, do the following.

1. Select the event to be split.

To split multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple events on page 64.

2. Place the cursor at the timeline position where the split will occur. 

Or, select your time range, if applicable.

3. Split the event(s) by doing one of the following:

• Press the  key.
• From the Edit menu, choose Split.

One event

Split position

Two events

Original event

Split position

Information is available, but will not play back.

Original event

Split position

Two events

Separated events

Ctrl Shift

S
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Splitting without a selection

All events will be split at the cursor’s position (unless the event is locked). The split will 
occur across all tracks.

Splitting event selection

Only the selected events will be split at the cursor’s position.

Splitting time only selection

Unless locked, all events within the time selection will be split at the starting and ending 
points of the time range. The split will occur across all tracks.

Events before splitting Events after splitting

Events before splitting Events after splitting

Events before splitting Events after splitting
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Splitting a time and event selection

Only selected events within the time selection will be split at the starting and ending points 
of the time range. 

Using the Ripple Edits 

Vegas Pro includes a Ripple edit feature. This feature is a timeline based procedure that 
allows you to cut, delete, and paste events or portions of events within a time selection and 
simultaneously adjust existing events’ timeline position on a selected track. The existing 
events’ timeline position is adjusted by the total amount of the time selection that is being 
cut, deleted or pasted from the clipboard.

You may turn on Ripple Edit mode by clicking its Toolbar button ( ) or pressing the 
 shortcut keys.

Ripple edits are only available when there is a time selection present.

Cutting events in ripple mode

Cutting events or portions of events removes them and their time information from their 
respective tracks. This information is placed on the clipboard from which you may paste the 
information back into your project.

To cut events, do the following:

1. Click the Ripple Edits button ( ) on the Toolbar.

2. Click on the event to be cut, if applicable. Otherwise, skip to step 3.

To cut multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple events on page 64.

Events before splitting Events after splitting

Ctrl + L

Ctrl Shift
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3. Select your time range. 

4. Cut the event to the clipboard by doing one of the following:

• Press the  keys.
• Click the Cut button  on the Toolbar. 
• From the Edit menu, choose Cut.

The cut events and their time information are removed from the 
selected track(s) and placed on the clipboard. Existing events in the selected track(s) are 
adjusted to occupy the space created by the cut.

Cutting time selection with ripple mode

Events within the time selection are reproduced and placed on the clipboard. Also, the time 
information is placed on the clipboard. Existing events occurring after the time selection are 
moved forward in the project by the length of the time selection. 

Cutting time and event selection with ripple mode

Events and portions of events within the time selection are reproduced and placed on the 
clipboard. Also, the time information is placed on the clipboard. Existing events occurring 
later than the time selection are moved forward by the length of the time selection. Only 
tracks containing selected events are affected by the ripple edit.

Events before cut Clipboard contents Events after cut

Events before cut Clipboard contents Events after cut

Ctrl + X

Existing events are 
adjusted to occur 
sooner in the project

Existing events are 
adjusted to occur 
sooner in the project

This graphic
is showing
crossfades.
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Deleting events in ripple mode

Deleting events or portions of events removes them and their time information from their 
respective tracks. However, this information is not placed on the clipboard. Existing events 
are adjusted forward when information is deleted from a selected track.

To delete events, do the following:

1. Click the Ripple Edits button ( ) on the Toolbar.

2. Click on the event to be cut, if applicable. Otherwise, skip to step 3.

To cut multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple events on page 64.

3. Select your time range.

4. Delete the event(s) by doing one of the following:

• Press the  key.
• From the Edit menu, choose Delete.

Deleting time selection with ripple mode

Events within the time selection and their time information are 
removed from the project. Existing events occurring after the time selection are moved 
forward in the project by the length of the time selection. When information is deleted from 
your project, it is not placed on the clipboard. 

Events before delete Clipboard contents Events after delete
Deleted information is not 
placed on the clipboard.

Ctrl Shift

Delete

Existing events are 
adjusted to occur 
sooner in the project
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Deleting a time and event selection with ripple mode

Events within the time selection and their time information are removed from the project. 
Existing events occurring after the time selection are moved forward in the project by the 
length of the time selection. When information is deleted from your project, it is not placed 
on the clipboard.

Pasting events in ripple mode

Once information is copied to the clipboard, you may choose a variety of ways to paste the 
clipboard items into tracks. For more information, see Pasting events on page 68. The following 
procedures explain pasting information when Ripple mode is enabled. Vegas Pro always 
pastes at the cursor’s position along the timeline.

To paste events from the clipboard, do the following:

1. Click the Ripple Edits button ( ) on the Toolbar.

2. Move the cursor to the desired timeline location.

3. Click either the track number or within the track where you want to paste the event.

 

If you are pasting multiple events from different tracks, Vegas Pro automatically creates 
new tracks as needed for events, or simply places events in existing tracks.

4. Paste the event into the track by doing one of the following:

• Press the  keys.
• Click the Paste button  on the Toolbar.
• From the Edit menu, choose Paste.

Clipboard information is pasted at the cursor’s position on the selected 
track. Existing track events or portions of events after the cursor are 
adjusted to occur later in the project. The amount of adjustment is 
based on the total length of the information being pasted.

Events before delete Clipboard contents Events after delete
Deleted information is not 
placed on the clipboard.

This graphic is showing
crossfades.

Existing events are 
adjusted to occur 
sooner in the project

Click either to select the track
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Pasting single track information with ripple mode

The information on the clipboard determines how many tracks will be affected when you 
paste. If you have copied or cut information from one track, only the selected track will be 
affected by the pasted event and time information. 

Pasting multitrack information with ripple mode

When you have copied or cut information from multiple tracks, how the information is 
pasted is determined by the track that you select for the paste. Vegas Pro will add tracks if 
necessary or simply paste the information into an existing track. 

Clipboard contents Events before paste Events after paste

Clipboard contents Events before paste Events after paste

Paste
position 

Newly pasted 
event

Existing event is 
adjusted later in
the project.

Information requires
three tracks

Paste
position 

Selected
track to
paste

Newly pasted
events

Since the top track was selected and three
tracks exist, no new tracks were created.
Existing events on the tracks was adjusted
later in the project.

Information requires
three tracks

Paste
position 

Selected
track to
paste

Newly pasted
events

Since the third track was selected and the
clipboard information required three tracks,
Vegas Pro added two more tracks.

New
track

New
track
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Accessing event properties

Vegas Pro allows you to adjust individual event properties. When you set an event’s 
properties different from the original referenced media, the original referenced media is not 
affected. The event settings are only used in Vegas Pro.

You may view an event’s properties by doing the following:

1. Right-click the event to display a shortcut menu.

2. From the shortcut menu, choose Properties. The Event Properties dialog will appear.

The event properties settings that you may change are the Active take’s name, its pitch shift 
value, its switch use, and its normalization.

Active take name

Referenced media’s file path
Media attributes

Pitch shift settings

Event switches
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Changing the active take’s name

Because Vegas Pro is a non-destructive audio editor, the new name that you give to an event 
does not affect the referenced media files name. In fact, you are simple giving the event a 
new take name. Typically, you would change an event’s name after recording multiple takes 
into a track or event. For more information, see Working with multiple recorded takes on page 
148.

To change an event’s name, do the following:

1. Right-click the event to display a shortcut menu.

2. From the shortcut menu, choose Properties. The Event Properties dialog will appear.

3. Type the new name in the Active take name field. (If the name is not selected, click in the 
field and select the name and then retype it.)

4. Click the OK button to set the new take name.

Viewing the take name

When you change an event’s name the new name will appear in the event’s Take list that 
you may access by doing the following:

1. Right-click the event to display a shortcut menu. 

2. From the shortcut menu choose Take. A sub-menu list of takes will appear. 
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Displaying take names on event

You may also see the take names right on the events in the Track View. The events in your 
project will display their respective active take names in the lower left portion of the 
waveform. Enable the Show active take names in events check box on the Preferences dialog to 
use this feature.

To enable this preference, do the following:

1. From the Options menu, choose Preferences. The Preferences dialog will appear.

2. Click the Show active take names in events check box to enable it.

 

3. Click the OK button to set the preference. 

Each event in your project will display their respective take names.

Note: To disable this feature, repeat steps 1-3 
and “uncheck” the Show active take names in 
events check box.

Before preference
is enabled

After preference
is enabled
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Using the pitch shift

Vegas Pro allows you to apply pitch shift to selected events. A pitch shift is a way speed up or 
slow down the audio to modify its timbre or fit the audio into a certain length of time. 
Generally, when you increase an event’s pitch, it “speeds up” and the events overall length is 
shortened. Conversely, when you decrease an event’s pitch, it “slows down” and lengthens 
the event.

The semitone range in Vegas Pro is -24 to 24. Twelve semitones equal one octave, so you 
may increase or decrease an event up to two octaves. Within a semitone is a finer pitch 
adjustment called cents. One hundred cents equal on semitone, so you have quite a range to 
finely adjust an event’s pitch. Increasing or decreasing cents affect the overall length of the 
event, but in smaller increments. 

To change an event’s pitch shift, do the following:

1. Right-click the event to display a shortcut menu.

2. From the shortcut menu, choose Properties. The Event Properties dialog will appear.

3. Adjust the pitch shift in the Semitone, Cents, or both using the arrows or simply typing in 
the desired value. 

4. Click the OK button to set the pitch shift for the event.

Original event

Event with pitch shift 
of 12 or one octave “speeds up”

Event with pitch shift
of -12 or one octave “slows down”
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Setting event switches

You may apply event switches via the properties dialog. Switches allow you to edit specific 
track events by muting, locking, looping, or normalizing the waveform. You may apply one 
or all switches to an event. More information on using switches is in the next section.

To change apply a switch from the Event Properties dialog, do the following:

1. Right-click the event to display a shortcut menu.

2. From the shortcut menu, choose Properties. The Event Properties dialog will appear.

3. Click the check box(es) of the switch that you want to apply to the event. 

4. Click the OK button to set the switch(es) for the event.

Using event switches 

Event switches are functions that you can apply to events. You may apply switches to a 
single-selected event or multiple-selected events at the same time. Switches allow you to 
edit specific track events by muting, locking, looping, or normalizing the waveform. You may 
apply one or all switches to an event.

You may access switches from the Edit menu and choosing Switches to display its sub-menu. 
Or, you may right-click a selected event and choose Switches to display its sub-menu. In 
addition, you may access switches via the Events Properties dialog, which was discussed in 
the previous section.

Right-click
event
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Below are brief descriptions of how an event is affected when each switch is used.

• Mute prevents the event from playing back, but it may be moved along the timeline.
• Lock prevents the event from being moved along the timeline, but it will play back.
• Loop allows you to extend the event along the timeline (in a loop) by dragging the right 

edge of the event. Vegas Pro loops the entire event’s waveform not a displayed portion. 
• Normalize maximizes the event’s volume without clipping it during playback. 

 Muting an event

You may mute an event to prevent it from playing back. Mute may be applied to one or more 
selected events. When you switch an event to mute, the Switch sub-menu displays a check 
mark indicating that Mute is enabled. The event remains muted until you disable the switch.

To mute an event, to do the following:

1. Click on the event to be muted.

To mute multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple events on page 64.

2. From the Edit menu, choose Switch and then Mute from the sub-menu.

Unmuting an event

1. Click the muted event(s).

2. From the Edit menu, choose Switch to display the sub-menu. The Mute switch will have a 
check mark.

3. From the sub-menu, choose Mute to disable it on the selected event(s).

Note: You may also access the event’s 
properties and deselect the Mute check box.

Ctrl Shift

Selected event 
before mute

Selected event after
mute is applied
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Locking an event

You may lock an event to prevent it from being moved or edited. Lock may be applied to one 
or more selected events. When you switch an event to lock, the Switch sub-menu displays a 
check mark indicating that Lock is enabled. The event will remain locked until you disable 
the switch.

To lock an event, to do the following:

1. Click on the event to be locked.

To lock multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple events on page 64.

2. From the Edit menu, choose Switch and then Lock from the sub-menu.

Unlocking an event

1. Click the locked event(s).

2. From the Edit menu, choose Switch to display the sub-menu. The Lock switch will have a 
check mark.

3. From the sub-menu, choose Lock to disable it on the selected event(s).

Note: You may also access the event’s 
properties and deselect the Lock check box.

Ctrl Shift

Selected event 
before lock

Selected event after
lock is applied
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Looping an event

You may loop an event so that you can extend it along the timeline by dragging the right 
edge of the event. Loop may be applied to one or more selected events. When you switch an 
event to loop, the Switch sub-menu displays a check mark indicating that Loop is enabled. 
The event will remain looped until you disable the switch.

To loop an event, to do the following:

1. Click on the event to be looped.

To loop multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple events on page 64.

2. From the Edit menu, choose Switch and then Loop from the sub-menu.

Unlooping an event

1. Click the looped event(s).

2. From the Edit menu, choose Switch to display the sub-menu. The Loop switch will have a 
check mark.

3. From the sub-menu, choose Loop to disable it on the selected event(s). The original 
waveform is restored.

Note: You may also access the event’s 
properties and deselect the Loop check box.

Ctrl Shift

Selected event 
before loop

Selected event after
loop is applied Drag the right edge

to extend the event
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Normalizing an event

You may normalize an event to maximize its volume, based on the waveform’s highest peak, 
without clipping the event during playback. Normalize may be applied to one or more 
selected events. When you switch an event to normalize, the Switch sub-menu displays a 
check mark indicating that Normalize is enabled. The event will remain normalized until 
you disable the switch.

To normalize an event, to do the following:

1. Click on the event to be normalized.

To normalize multiple events, use the  key, the  key, or the Selection Edit tool 
 to select the events. For more information, see Selecting multiple events on page 64.

2. From the Edit menu, choose Switch and then Normalize from the sub-menu.

Recalculating an events normalization

When you normalize an event, Vegas Pro analyzes the event and raises the volume based on 
the waveform’s highest peak and then adjusts the rest of the event accordingly. However, if 
while you are editing the event, you may have adjusted its edge to exclude the highest 
waveform peak. In this case, you may want to recalculate the event’s normalization.

You may have Vegas Pro recalculate the normalization by doing the following:

1. Right-click the event to display a shortcut menu.

2. From the shortcut menu, choose Properties. The Event Properties dialog will appear.

Ctrl Shift

Selected event 
before normalize

Selected event after
normalize is applied

Highest peak used
for normalization

Highest peak used
for recalculating the
normalization

Event edited after
normalization 

before editing
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3. Click the Re-calculate button to normalize the event again. 

4. Click the OK button to normalize the event.

Disabling event normalization

1. Click the normalized event(s).

2. From the Edit menu, choose Switch to display the sub-menu. The Normalize switch will 
have a check mark.

Note: You may also access the event’s 
properties and deselect the Normalize check 
box.

Using event envelopes (ASR)

You may apply envelopes to individual events. Envelopes, also known as ASRs (attack, 
sustain, and release), give you the ability to control each event’s volume. The fade-in, fade-
out, and over-all level of the event may be controlled. These envelopes are different than 
track envelopes in that they move with the event. Track envelopes affect the entire track 
and do not move with the events. 

When you place an event into your project, Vegas Pro adds “handles” that are used to set the 
envelope. As you use these handles, a volume line will appear indicating how the event is 
being affected. Also, the waveform will graphically display the volume change.

Volume lineEnvelope
handles
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Setting an event’s volume

When you place the mouse pointer at the top of the event the pointer changes to a hand 
cursor ( ) with which you may use to lower the event’s overall volume. 

To set the event’s volume, do the following:

1. Place the mouse pointer at the top of the event.

2. When you see the envelope cursor ( ), click and drag the volume line to the desired 
level. As you drag the volume line down Vegas Pro displays the event’s decibel level.

3. Release the mouse to set the volume.

Setting an event’s fade in and out

The event handles allow you to affect an event’s fade in and out volume. Also, you can 
change the type of curve that the event uses to control the volume’s fade in or out.

To set the event’s fade in or out do the following:

1. Place the mouse pointer on a handle and the pointer changes to the envelope cursor ( ).

2. Click and drag the envelope cursor, the volume line appears. As you drag the cursor, 
Vegas Pro displays both the time, in the event, when the volume will be maximized and 
its decibel level. 

3. Release the mouse to set the fade in or out.

Volume line

Decibel level

Time and
decibel

Volume line

Fade in Fade out

Volume line

Time and
decibel
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Changing the event’s fade curve

You can set the fade curve (fast, linear, or slow) that an event uses to raise or lower the 
volume over time.

There are two ways to access the fade curve types. You may right-click anywhere in the 
event’s fade-in or -out region to display a shortcut menu. From the shortcut menu, choose 
Fade type to display the fade types sub-menu. Click the desired fade type to set it.

The second way is to go directly to the fade types sub-menu. When the envelope cursor ( ) 
is displayed, right-click to display the sub-menu. Click the desired fade type to set it.

Fade in curves Fade out curves

Fast

Linear

Slow

Right-click in region Right-click with envelope 
cursor showing
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Crossfading events

Vegas Pro allows you to crossfade between two events on the same track. Crossfading gives 
you the ability to fade out one event’s volume while another event’s volume is fading in on 
the same track. This function allows you to introduce transitions between events on a track. 

When you place an event into your project, Vegas Pro adds “handles” that are used to set the 
crossfade. These handles allow you to adjust the crossfade, even when you are using 
automatic crossfades. Volume lines also appear indicating how and when the events’ volume 
are being affected. Also, their respective waveforms will graphically display how the 
crossfade volume is affected. 

Automatic crossfades

On the Toolbar, the Automatic Crossfade button ( ) allows you to overlap event edges 
and Vegas Pro will apply a crossfade for you. Simply, click  the button or press the  
short cut key to enable or disable Automatic Crossfades.

The crossfade “x” will automatically adjust itself as you move one event over another as long 
as one event’s edge is crossing the other event’s edge. In the case where edges do not cross 
(one event is wholly contained in another), the shorter event will be place “on top” of the 
longer event. You may still set a crossfade in this situation. For more information, see 
Manually setting a crossfade on page 114.

Use the event’s handles to adjust the desired crossfade between the two events.

Fade in

Handles
volume line

Fade out
volume line

Drag handle

X

Events before crossfade Events after crossfade

Drag the event to
overlap the other
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Manually setting a crossfade

If you are using automatic crossfades, Vegas Pro will not insert a crossfade if a shorter event is 
placed on “top” and within the same time of a longer event. In this case, during play back, 
the longer event will begin playing, then the shorter event will play, and then the longer 
event will resume playing at the timeline position.

To manually set the a crossfade between the edges of the overlapping events, do the 
following:

1. Place the mouse pointer on one of the shorter event’s handles. The envelope cursor will 
appear ( ).

2. When you see the envelope cursor appear ( ), click and drag the handle to the desired 
position.

3. Repeat Step 1-2 to set the second crossfade, if necessary, or to edit the crossfade.

Changing crossfade curves

You can set the crossfade curve(s) that Vegas Pro uses to fade in and out between two events. 
The crossfade curve determines how Vegas Pro raises and lowers the events’ volume over 
time.

Events without crossfade Events with manual crossfade

Fast in 

Linear in
 

Slow in

Fast in

Slow in

Linear in

Linear in

Fast in

Slow in

Slow out

Linear out

Fast out

Fast out

Slow out

Fast out Linear out

Linear out

Slow out
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You may change the crossfade curve by doing the following:

1. Right-click anywhere in the crossfade region to display a shortcut menu. 

2. From the shortcut menu, choose Fade type to display the fade types sub-menu. 

3. Click the desired fade type to set it.

Changing the crossfade volume

You may set a cross-faded event’s volume and Vegas Pro will adjust the crossfade “x” to 
graphically reflect the volume change. When you change the volume in the cross-faded 
region, the event being faded in is affected. For the event being faded out, simply adjust its 
volume. For more information, see Setting an event’s volume on page 111.

When you place the mouse pointer at the top of the cross-fade region, the pointer changes 
to a hand cursor ( ) with which you may use to lower the faded-in event’s overall volume. 

To set the cross-fade volume, do the following:

1. Place the mouse pointer at the top of the cross-fade region.

2. When you see the envelope cursor ( ), click and drag the volume line to the desired 
level. As you drag the volume line down Vegas Pro displays the event’s decibel level.

3. Release the mouse to set the volume.

Right-click in crossfade region

Fast in - Slow out

Linear in - Linear out

Slow in - Fast out

Fast in - Fast out

Slow in - Slow out

Linear in - Fast out

Linear in - Slow out

Fast in - Linear out

Slow in - Linear out

Volume line

Decibel level
for faded-in
event

Crossfade before
volume change

Crossfade after 
volume change
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Grouping events

Vegas Pro allows you to group events together within tracks or across separate tracks. Once a 
group is created, all the events within it may be moved together as a unit and have event 
specific edits applied at the same time. Edits that may be applied are copy, paste, and delete. 
Or, you may apply an event switch to the entire group at once. 

You may still edit properties of individual events within a group without affecting the other 
group events. For more information, see Accessing event properties on page 101.

Creating a new group

Grouping is useful when you want to preserve timing of events and move them together 
along the timeline or duplicate the group and distribute it along the timeline. 

To create a new group, do the following:

1. Select the events you want to group. Use the  key, the  key, or the Selection Edit 
tool  to select them. For more information, see Selecting multiple events on page 64.

2. After the events are selected, you may group them in one of three ways:

• From the Edit menu, choose Group to display a sub-menu and then choose Create New.

• On one of the selected events, right-click to display a shortcut menu. From the shortcut 
menu choose Group and then Create New.

• Press the  shortcut key to create the group.

If you want to add events to an existing group, simply select the events and the group and 
repeat the above steps.

Note: Events can only be in one group at a 
time. Adding an event to an existing group 
essentially deletes the old group and creates a 
new one to include all of the selected events.

Ctrl Shift

G
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Removing an event from a group

You may remove a single event from a group. The other grouped events will not be affected 
when you remove an event from the group. Also, the event you are removing from the group 
is not deleted from the project, but remains at its timeline position.

To remove an event from the group, do the following:

1. On the event you want to remove from the group, right-click to display a shortcut menu.

2. From the shortcut menu, choose Group and then choose Remove From on the sub-menu. 
The event will be removed from the group, but keep the rest of the grouped events intact.

3. Repeat Steps 1-2 to remove more events from the group.

Clearing a group

You may ungroup events by clearing the group. Clearing a group does not delete or remove 
events from your project. The events will remain at their timeline position.

To clear a group, do the following:

1. Select one of the grouped events. The entire group will be selected. 

2. After the group is selected, you may clear it one of three ways:

• From the Edit menu, choose Group to display a sub-menu and then choose Clear.

• On one of the selected events, right-click to display a shortcut menu. From the shortcut 
menu choose Group and then Clear.

• Press the  shortcut key to clear the group.

3. From the Edit menu, choose Group and then Clear from the sub-menu.

The events will be released from the group and may be moved or edited independently.

U
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Using the Trimmer window

Events may be placed in the Trimmer window directly from your project, in which case they 
are referred to as media files. The Trimmer allows you to work with one media file at a time. 
Many of the shortcut keys and right-click shortcut menus are available in the Trimmer. 

You, also, may place a media file directly into the Trimmer from the Vegas Pro Explorer 
window. 

The Trimmer window may be placed in the Docking area of Vegas Pro or “float” over the 
work area. For more information, see Window Docking Area on page 20.

From the View menu choose Trimmer or press the  shortcut keys to display the 
Trimmer window, if it is not displaying already.

History drop-down This drop-down list displays all the events in your current project. You may 
open a media file in the Trimmer by selecting its filename from the list.

Marker bar This area displays the markers that you place along the media file’s timeline. 
The marker bar is identical to the one in the Track View (p. 77).

Save button ( ) If you have added markers or regions to a media file in the Trimmer, you can 
save that data to the referenced media file for use in the sound editor or in 
later projects.

Selection bar The selection bar is identical to the one found in the Track View. Use it to select 
portions of audio that you would like to place on a track or for setting regions 
(p. 65).

Selection tab Click this tab to bring the Trimmer to the front when it is “behind” other 
docked windows.

Sound editor button ( ) This button opens the event in your sound editor application (p. 88). 

Transport bar The Transport bar is identical to the one found in the Track View (p. 19).

Ruler The ruler is identical in functionality as the one in the Track View (p. 18).

Zoom buttons These buttons are identical to the ones in the Track View (p. 24). 

Alt + 2

Transport bar

History drop-down Save

Open sound editor

Zoom in/out

Ruler
Marker bar

Selection bar

Selection tab
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Showing an event in the Trimmer

Showing an event in the Trimmer is actually displaying the event’s referenced media file. 
You may place a media file directly into the Trimmer from the Vegas Pro Explorer. The main 
functions of the Trimmer are to select portions of a media file to place in the project or to 
add regions or markers to the media file for use later in other projects or a sound editor.

Showing an event from the Track View

This procedure is typically used when you want to select a portion of the media file to place 
on tracks in your project or add regions or markers to the event’s referenced media file.

To show an event’s media file in the Trimmer, do the following:

1. Select the event.

2. Right-click to display a shortcut menu. From the shortcut menu, choose Show in Trimmer. 
The event’s entire referenced media file will appear in the Trimmer window.

Note: If the event in your project is only using 
a portion of a larger media file, the Trimmer 
will “select” the portion being used.

Portion being used
in the project

Entire media file
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Placing a media file from the Vegas Pro Explorer

This procedure is a useful way to select a portion of a long file and place it in the project. 
Rather than placing the entire event and cutting the unwanted portions. For example, if you 
had a long narration and only wanted to use the first five seconds, you could place the file 
into the Trimmer, select the five seconds, and drag it to the Track View. 

1. In the media list, select the media file.

2. Drag and drop the file to the Trimmer window. The media file will appear the Trimmer.

Working in the Trimmer window

The Trimmer window’s main function is to allow you to work with one media file for placing 
portions of it on a track and adding regions and markers. The Trimmer window also allows 
you to play back the media file and export it to your sound editor program.

Placing smaller portions of the event on track

After you have placed a media file in the Trimmer, you may select a segment of it and place 
it in your project. Selecting a portion of the media file will not affect the event already on a 
track. Vegas Pro treats the smaller portion as a separate event even though it is from the 
same reference media file.

To place a smaller segment into your project, do the following:

1. Click and drag the cursor or use the Selection bar to make a time selection. The portion 
of the event you want to place will be “inside” the selection.

Drag and drop the 
media file in the Trimmer

Drag from the
Trimmer...

...to a project
track
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2. Place the mouse pointer in the selected region and click and drag the portion onto the 
desired track.

Adding regions and markers to a media file

The Trimmer allows you to add markers and regions to a media file the same way you add 
them to your project. However, these markers and regions are different from project markers 
and regions, which was described earlier in this manual. For more information, see Using 
project markers and regions on page 77. The difference between the two is simply that project 
markers and regions affect the project, while media file markers and regions are embedded in 
the media file.

When you add a marker or regions to a media file, Vegas Pro does not add the markers to the 
project. Markers and regions that are added from within the Trimmer are only temporary. 
You must save them if you want to use them again after you close the project. After the 
markers and regions are added and saved to the media file, they will be available when you 
open the media file in a sound editor program or in the Vegas Pro Trimmer.

Markers are placed at the cursor’s position. You may also place a marker on-the-fly while the 
media file is playing back. Markers appear as red tags above the ruler.

A region is placed at the cursor’s position or at either end of a time selection. You may also 
place a region on-the-fly while the media file is playing back. A region appears as green tags 
above the ruler.

To add markers or regions do the following:

1. Position the cursor or make a time selection.

2. Place the marker or region in one of the following ways:

• From the Insert menu, choose Marker or Region.
• Right-click on the Trimmer Marker bar and choose Marker or Region from the shortcut 

menu.
• Press the  (marker) or  (region) shortcut keys.

3. Click the  button to save the markers and regions to the media file.

After a marker or region is placed, you may move, rename, and delete them from the media 
file. These procedures are identical to project markers and regions. For more information, see 
Using project markers and regions on page 77.

Marker Region

M R
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Opening the sound editor from the Trimmer

The Trimmer allows you to open your selected sound editor application to preform 
destructive edits to the media file. After you make the necessary changes and save the file in 
the sound editor, Vegas Pro will automatically update the event using that media file. 
However, remember to keep the media file’s name and location the same. Otherwise, you 
will need to import the edited media file into Vegas Pro again. For more information, see 
Using a sound editor program on page 88.

There are a few ways to open your sound editor from the Trimmer, when it is the active 
window: 

• Click the  button.
• Right-click the media file and choose Open in Sound Editor from the shortcut menu.
• Press the  shortcut keys.Ctrl + E
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6

Working with 
Tracks
Vegas Pro is a true multitrack mixing environment. Tracks are the containers for audio 
events, which you place and arrange. A track can contain different events. There is not a 
limit to the number of tracks you use in Vegas Pro. Because tracks are containers for events, 
you may use track functions to affect all the events on them. 

Vegas Pro provides track functions that allow you organize your project and apply track 
features that enable you to achieve your project’s goals. This chapter explains track editing, 
techniques, and features that you can apply to your project’s tracks.

Track basics

Whether you are starting your first project or opening an existing one, you will need to 
manage the tracks in your project. The following procedures explain basic track 
management. The terms used to describe the track “parts” are explained in the Quick Start 
chapter of the manual. For more information, see Track navigation on page 35.

Adding an empty track

Typically, when you add an event to your project by double-clicking it from the Explorer 
window, Vegas Pro automatically creates a new track and places the event on it.

You can add empty (eventless) tracks to a project. These tracks can be used to directly 
record into, or serve as placeholders for specific audio that you will add later. For example, 
your project may contain special audio, but it needs to be recorded and mixed or retrieved 
from another location.

To add an empty track, do the following:

1. Place the mouse pointer in either the Track View or the Track List.

2. Right-click to display a shortcut menu.

3. From the shortcut menu, choose Insert Audio Track.
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Alternatively, you may add an empty track from the Insert menu by choosing Audio Track 
or pressing the  shortcut keys. Vegas Pro creates and adds an empty track at the 
“bottom” of the Track List. 

4. Repeat steps 1-3 to add more empty tracks.

Duplicating a track

You may duplicate tracks in your project and all the events contained on them. When a 
track is duplicated, the duplicated track is place directly below the original track. Other 
existing tracks are moved “down” on the Track List. You may duplicate one track or choose 
multiple tracks to duplicate at a time.

To duplicate a track, do the following:

1. Place the mouse pointer over the track that you want to duplicate.

Note: To select multiple tracks, click them while 
holding down either the  key to select adjacent 
tracks, or the  key to select random tracks.

2. Right-click and choose Duplicate Track from the shortcut menu.

Right-click to
view pop-up
menu

Ctrl + Q

Before track is added
After track is added

Shift

Ctrl
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3. Repeat steps 1-2, if necessary, to duplicate more tracks.

Deleting a track

You may delete tracks from your project and all events contained on them. You may delete 
one track or choose multiple tracks to delete at a time.

To delete a track, do the following:

1. Place the mouse pointer over the track that you want to delete.

Note: To select multiple tracks, click them 
while holding down either the  key to 
select adjacent tracks, or the  key to select 
random tracks.

2. Right-click and choose Delete from the shortcut menu. 

Or, from the Edit menu, choose Delete.

3. Repeat steps 1-2, if necessary, to delete more tracks.

Shift

Ctrl
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Naming or renaming a track

Every track in your project has a Scribble Strip where you can type a name for the track. The 
track name may be up to 255 characters. (If you do not see the Scribble Strip, expand the 
track to reveal it. When a track’s view is minimized, the Scribble Strip does not display.)

You may name or rename the track at any time by doing the following:

1. Double-click in the Scribble Strip and type the track name. 

Or, right-click the on the track to display a shortcut menu. Choose Rename from the 
shortcut menu. Any existing name is highlighted on the strip. Type the new track name.

2. Press the  key to save the track’s name.

Organizing tracks

Vegas Pro is flexible when organizing your tracks. You can leave your tracks alone and work 
with them as they are added. How you organize tracks is strictly based on your preferences. 
However, if your project contains several tracks, organizing them can save time in editing. 

Reordering tracks

When you create tracks, Vegas Pro arranges them in the order that they were added. You 
may reorder the tracks. Only the order changes in the Track List and Track View; project 
playback is unaffected. You may reorder one or more tracks at a time.

To move a track, do the following:

1. On the Track List, place the mouse pointer on the track that you want to move.

2. Drag and drop the track to the new position in the Track List.

3. Repeat step 2, if necessary, to continue moving the track up or down.

Note: To select multiple tracks, click them 
while holding down either the  key to 
select adjacent tracks, or the  key to select 
random tracks.

Double-click and type the name Right-click

If the track already has been 
named, you will see the previously
entered name.

Enter

Shift

Ctrl
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Changing a track’s color

When you add a track to Vegas Pro, a color is assigned to that track. This color may be 
changed. This feature is useful if you want to organize similar tracks together. For example, 
you may want all your background vocals to have a different color from your lead vocals.

To change a track’s color, do the following:

1. In the Track List, right-click on a track to display a shortcut menu.

2. From the shortcut menu, choose Track Color to display a sub-menu.

3. From the sub-menu, select a color for the track’s number and events.

Changing track height

There are two ways to control track height in your project: toggling the tracks’ height and 
expanding an individual track.

Toggling the tracks

You may change an individual track’s height in the Track View by clicking the view ( , , 
) buttons on the track. Alternatively, you may use the +  or  shortcut keys to 

toggle through different track-height scenarios. The shortcut keys affect all tracks in your 
project and make them the same height.

Click Track height Press command keys

+  or 

+  or 

+  or 

Ctrl + Shift 

Ctrl + Shift 

Ctrl + Shift 

Ctrl + Shift 
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Expanding an individual track

You may resize a track by “pulling” the lower or right portion of it. Place the mouse pointer 
at the bottom or right side of the track. The pointer turns into an up/down or left/right 
arrow. 

Click and drag while moving the arrow up/down (height) or left/right (width). Release the 
mouse to set the desired track size. 

Working with tracks

Each track in your project has its own controls, faders, and sliders. You can work with these 
controls to affect the event(s) that are contained on the track. Each track’s controls work 
independently from the other tracks in your project.

Using the track fader

This fader controls the volume of the events on the particular track. The fader’s range is -.inf 
to 12dB. To adjust the fader, simply click and drag it to the desired volume level. As you drag 
the fader, you will see the volume level displayed to the left of the fader. Double-clicking the 
fader will reposition it to 0.0 dB.

Note: You may also move the fader by 
clicking it and using the right or left arrow keys 
on the keyboard.

Before

After

Before

After

Double-click the slider
to reset to 0.0dB.

Click and drag left Click and drag right
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Muting a track

This track button enables you to temporarily disable playback of the track, so you can focus 
on another track’s event(s). When a track is muted, it appears “grayed out” on the Track 
View. You may mute more than one track at a time.

To mute the track, simply click the mute ( ) button. Click it again to “unmute” the track.

Soloing a track

This track button isolates a track’s events for playback and mutes the other tracks’ events, so 
you can focus on a track. When you solo a track, the other tracks will be “grayed out” on the 
Track View. You may solo more than one track at a time.

To solo the track, simply click the solo ( ) button. Click it again to restore all tracks for 
playback.

Before muting the track After muting the track

Muted
track

Before applying Solo to the track After applying Solo to the track

Soloed
track
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Adding track FX

Each track in your project has built-in FX: equalization (EQ), compression, and Noise Gate. 
These FX can be accessed by clicking the FX ( ) button on the track. When you apply 
Track EQ, Track Compression, or Noise Gate FX, the settings that you specify will only 
affect that track and the events contained on it. 

These FX give you powerful flexibility and control of a track’s events. How to set and work 
with these controls is discussed later in this manual. For more information, see Track FX on 
page 155.

Assigning a track to a bus

A bus is where various track signals are mixed together and output. If your project contains 
multiple stereo busses, you may assign a track to a specific bus output. 

To assign a track to a bus, do the following:

1. Click the Bus ( )button to display a drop-down list of available busses. 

2. From the drop-down list, choose the bus to which you want to output the track.

Note: If you only have one stereo bus in your 
project, this button will not appear in the tracks 
controls. For more information, see Working 
with project properties on page 43.

Compression FXEqualization FXNoise Gate FX

Select a bus 
for playback
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Assigning a track to an auxiliary bus

An auxiliary bus allows you to send track signals to a secondary bus independent of the 
primary bus. Auxiliary busses are usually used to separate signals from the rest of the project. 
For example, if a musician in a studio only wants to listen to the guitar portion of the 
project, you can set up an auxiliary bus for that purpose. Then the musician can play his or 
her part while only listening to the guitar. 

An auxiliary bus do not affect the project’s overall playback. As shown in the previous 
section, the primary bus is set using the Bus ( ) button on a track’s toolbar. Setting up the 
auxiliary bus works differently.

To set up and auxiliary bus, do the following:

1. If you do not see the multipurpose slider, expand the track to display it.

2. Click on the multipurpose label to display a drop-down list.

3. From the drop-down list, choose the auxiliary bus output.

Note: If you only have one stereo bus in your 
project, the drop-down list will not appear. For 
more information, see Working with project 
properties on page 43.

Adjusting the auxiliary bus volume

When you select an auxiliary bus, you will need to adjust its playback volume with the fader. 
Auxiliary tracks’ volume are preset to -inf. dB (mute) for playback.

Multipurpose
label

Make sure the auxiliary bus is
different from the track bus.

Double-click the slider
to set its volume at 0.0 dB.
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Setting up to record into tracks

Vegas Pro allows you to record into single or multiple tracks. You may record into tracks that 
are empty or tracks that contain events.

However, before you record into a track you need to “arm” the track. Setting up a track for 
recording is simply done by clicking the Arm for Record ( ) button on the track(s). After 
you click this button, you will see a record meter appear on the track(s) to be recorded into.

More details on recording is discussed later in this manual. For more information, see 
Recording on page 141.

Using track envelopes

Track envelopes allow you to control volume and panning aspects of a particular track. 
Volume envelopes automate the volume used for events on a track, auxiliary bus, FX send, or 
all at the same time. A panning envelope automates the panning aspects used for events on 
a track.

Adding a volume envelope

The type of volume envelope that you add will determine what Vegas Pro component’s 
volume is automated. You may add volume envelopes to tracks, auxiliary busses, and FX 
sends. A volume envelope can be added to just one or all components at the same time. You 
can distinguish the volume envelopes by their color. 

The following procedure describes adding a track volume envelope; this procedure is 
identical for auxiliary busses and FX sends. The only exceptions being which component 
you select and the volume envelope’s color.

Envelope type Color
Track Blue
Auxiliary bus Magenta
FX send Green

Track is ready for recording Arm the track first
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To add a volume envelope, do the following:

1. Select the track that you want to add the volume envelope. (You may select multiple 
tracks.)

2. From the Insert menu, choose Audio Envelopes and then choose Volume. Or, press the  
key. A blue line appears across the track(s).

Adding envelope points

Once a volume envelope is placed, you may add points to it. These points will be used to 
move the envelope line so that the volume will be automated.

To add envelope points, do the following:

1. Place the mouse pointer on the volume envelope’s line. The mouse pointer appears as a 
hand ( ).

2. Right-click and choose Add Point from the shortcut menu. A square point appears on the 
envelope line.

Or, simply double-click to add a envelope point.

3. Repeat step 2 as to add more points on the envelope.

Note: If you add too many points, you may 
delete a point by right-clicking it and choosing 
Delete from the shortcut menu. Or, you may 
start over adding envelope points by selecting 
Reset All from the shortcut menu.

V

Volume envelope line

Or
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Setting the volume envelope points

Once the envelope points have been added, you may raise and lower them to different 
decibel (dB) levels along the timeline to automate the track’s volume. You may move one 
point at a time, even during play back and listen to the results in real-time. Also, you may 
set the type of fade curve between each envelope point.

To move an envelope points, do the following:

1. Place the mouse pointer on an envelope point. The mouse pointer appears as a hand ( ).

2. Click and drag the points to the desired position. As you move an envelope point, an 
information box displays both the point’s occurrence on the timeline and its decibel level.

3. Click either  or  to play back the project and check the timing of the envelope.

4. Repeat steps 2-3 until the envelope points are at the desired position.

Note: You may also set the volume by right-
clicking an envelope point and choosing a 
volume setting from the shortcut menu. Or, 
choose Select All from the shortcut menu to 
raise or lower all points on the envelope. 

Changing the volume fade curves

Between each envelope point, you may set the type of volume fade curve: fast, linear, or 
slow. From the selected envelope point, fade curves are applied to the volume lines that 
occur later on the timeline. 

To set the volume fade curve, do the following:

1. Right-click on a point to display a shortcut menu.

2. From the shortcut menu, choose the curve type. Curve types are applied to volume line. 

You can only set one point
at a time or use the Envelope
tool to select and move
multiple points at a time.

Or

Fast fade

Slow fade

Linear fade

As the graphic shows, you may have more
than one type of fade curve on an envelope.
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Hiding the volume envelopes

After you have set your volume envelopes on the tracks, you may hide them from the Track 
View. Hiding volume envelopes will not affect playback. The points that you set will still 
automate the volume, you simply will not see the volume envelope’s line until you display 
them again.

To hide a volume envelope, do the following:

1. From the View menu, choose Show Audio Envelopes. A sub-menu will appear. There will 
be a check mark next to Volume, indicating that those envelopes are currently displayed.

2. From the sub-menu, choose Volume. All volume envelopes in your project will no longer 
appear in the Track View.

3. Repeat steps 1-2 to display the volume envelopes again.

Removing track volume envelopes

You may remove a volume envelope from a track. When you remove the envelope, the 
events on the track will no longer have automated volume. Also, the volume envelope line 
will no longer be displayed. 

It is important to remember that when you remove a volume envelope from a track and then 
add a it again, you will need to reset the volume points.

To remove a volume envelope, do the following:

1. Select the track or tracks that you want to remove the volume envelope(s).

2. From the Insert menu, choose Audio Envelopes. A sub-menu will appear. There will be a 
check mark next to Volume, indicating that those envelopes are currently being used.

3. From the sub-menu, choose Volume. All volume envelopes on the selected tracks will be 
removed.
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Adding a panning envelope

A panning envelope allows you to control how a track’s events are mixed to either the right 
or left speaker. You may add panning envelopes to tracks, which can be assigned to an 
auxiliary bus and FX send. A panning envelope can be added to one or multiple tracks at the 
same time. A panning envelope line appears in red. 

To add a panning envelope, do the following:

1. Select the track(s) that you want to add the panning envelope.

2. From the Insert menu, choose Audio Envelopes and then choose Pan. Or, press the  
key. A red line appears across the track(s).

Adding pan envelope points

Once a pan envelope is placed, you may add points to it. These points will be used to move 
the envelope line so that the panning effect will be automated.

To add envelope points, do the following:

1. Place the mouse pointer on the envelope line. The mouse pointer appears as a hand ( ).

2. Right-click and choose Add Point from the shortcut menu. A square point appears on the 
envelope line. Or, simply double-click to add a envelope point.

3. Repeat step 2 as to add more points on the envelope.

Note: If you add too many points, you may 
delete a point by right-clicking it and choosing 
Delete from the shortcut menu. Or, you may 
start over adding envelope points by selecting 
Reset All from the shortcut menu.

P

Panning envelope line

Or
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Setting the panning envelope points

Once the envelope points have been added, you may move them to different panning values 
along the timeline to automate the track’s panning effect. You may move one point at a 
time, even during play back and listen to the results in real-time. Also, you may set the type 
of fade curve between each envelope point.

To move an envelope point, do the following:

1. Place the mouse pointer on an envelope point. The mouse pointer appears as a hand ( ).

2. Click and drag the points to the desired position. As you move a pan point, an 
information box displays both the point’s occurrence on the timeline and its decibel level.

3. Click either  or  to play the project and check the timing of the panning envelope.

4. Repeat step 2-3 until the envelope points are at the desired position.

Note: You may also set the pan by right-
clicking an envelope point and choosing a pan 
setting from the shortcut menu. Or, choose 
Select All from the shortcut menu to raise or 
lower all points on the envelope. 

Changing the pan fade curves

Between each envelope point, you may set the type of pan fade curve: fast, linear, and slow. 
From the selected envelope point, fade curves are applied to the pan lines that occur later on 
the timeline. 

To set the pan fade curve, do the following:

1. Right-click on a point to display a shortcut menu.

2. From the shortcut menu, choose the curve type to be applied to the pan line.

You can only set one point
at a time. Two are shown
for display purposes.

Or

Fast fade

Slow fade

Linear fade

As the graphic shows, you may have more
than one type of fade curve on an envelope.
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Hiding the panning envelopes

After you have set your panning envelopes on the tracks, you may hide them from the Track 
View. Hiding panning envelopes will not affect playback. The points that you set will still 
automate the panning, you simply will not see the panning envelope’s line until you display 
them again.

To hide a panning envelope, do the following:

1. From the View menu, choose Show Audio Envelopes. A sub-menu will appear. There will 
be a check mark next to Pan, indicating that those envelopes are currently displayed.

2. From the sub-menu, choose Pan. All panning envelopes in your project will no longer 
appear in the Track View.

3. Repeat steps 1-2 to display the panning envelopes again.

Removing track panning envelopes

You may remove a panning envelope from a track. When you remove the envelope, the 
events on the track will no longer have automated panning. Also, the panning envelope 
line will no longer be displayed. 

It is important to remember that when you remove a panning envelope from a track and 
then add a it again, you will need to reset the pan points.

To remove a panning envelope, do the following:

1. Select the track or tracks that you want to remove the panning envelope(s).

2. From the Insert menu, choose Audio Envelopes. A sub-menu will appear. There will be a 
check mark next to Pan, indicating that those envelopes are currently being used.

3. From the sub-menu, choose Pan. All panning envelopes on the selected tracks will be 
removed.
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Mixing multiple tracks to a single track

Vegas Pro allows you to mix down a time selection or an entire project to a single-track 
stereo event. However, if your project includes any muted tracks, Vegas Pro will not mix 
those events into the new mixed down track. The original tracks and their events are 
unaffected when you mix to a single track. 

Typically, you would use this feature when you are finished refining a few tracks and want to 
combine them. Also, when you mix multiple tracks to a single-stereo track, any envelope or 
track effects that you applied will be rendered into the newly mixed down track.

This option allows you to “destructively” process any FX that you want to commit.

To mix multiple tracks to a single-stereo track, do the following:

1. To mix specific events, make a time selection. Otherwise, skip to step 2 to mix the entire 
project.

2. From the Tools menu, choose Mix to New Track or press the  shortcut keys. The 
Mix to New Track dialog will appear.

The Mix to New Track dialog has settings that you can apply to the newly mixed track.

• From the Save in drop-down list, select the drive or folder to save the new media file.
• Type a new media file in the File name field.

• From the Save as type drop-down list, choose the file format (*.wav is the preset).
• From the Template drop-down list, choose an audio format from the template list.

• Click the Render entire project check box if you did not remove the time selection but 
want to include all the events in your project in the new mixed down track, except 
muted tracks.

Ctrl + M
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3. Click the Save button to mix down the time selection or project to a new track.

As the tracks are being mixed down, you will see a status bar appear in the lower left portion 
of Vegas Pro.

Note: You may cancel the rendering process 
by clicking the  button on the status bar.

After Vegas Pro mixes down the new track, it will appear at the bottom of the Track View. If 
you mixed down the entire project, you may delete the other tracks from the project, since 
they are all contained on the new track.

Creating a mix to new template

You may create your own templates for mixing down tracks or projects. When you create a 
template you may choose its name from the Template drop-down list in the Mix to New 
Track dialog.

To create a custom template, do the following:

1. From the Tools menu, choose Mix to New Track or press the  shortcut keys. The 
Mix to New Track dialog will appear.

2. Click the Custom button to display the Custom setting dialog.

The settings that you may change are as follows:

3. Click the  button to save the template.

Or, click the  button to delete a selected template.

Template Enter the name of your template Sample rate Choose a rate from the drop-down list
Description Enter the template’s parameters Bit-depth Choose a bit-depth from the drop-down list
Format Choose an audio format from the 

drop-down list
Channels Choose a channel option from the drop down-

list

Cancel
button

Status bar

Ctrl + M
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Recording
Vegas Pro will record into multiple mono or stereo audio tracks while simultaneously playing 
back existing audio tracks. You are limited only by the performance of your computer system 
and audio hardware. You may record into an empty track, a time selection, an event, or a 
combination of time and selection. Audio playback during recording is not recorded with 
the new audio.

Recording in Vegas Pro is a non-destructive operation. Even when recording into an 
existing event, you are not overwriting the data that is already displayed in that event. 
Instead, the data is recorded into a new take for that event. 

Setting up your equipment

Following are general setup scenarios. There are numerous ways to connect your equipment 
to your system. Refer to your equipment’s documentation for specific setup instructions. 

Basic setup

This setup includes a simple microphone and speaker that are connected to the computer’s 
sound card. With a more sophisticated microphone, you would typically want to use a 
preamplifier for input to the sound card.

Sound card out

Sound card in
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Setup with mixer

This setup includes a mixer where the speaker and microphone connect. The mixer is then 
connected to the computer’s sound card. Mixers usually have pre-amps built into them. This 
diagram does not show you an instrument or a physical preamplifier, such as a rack-mounted 
component. The reason for this omission is because these types of setup vary widely based on 
your mixer, instrument, and pre-amp type. Refer to your components’ documentation for 
specific setup configurations.

Setup with digital multitrack

This setup includes a digital multitrack recorder with an optional MIDI synchronization 
component. Usually you would have a mixer, microphone, etc. connected to these 
components. For simplicity, this diagram demonstrates that Vegas Pro can be used in this 
type of environment. As mentioned earlier, your particular setup may vary depending on 
your equipment. Refer to your components’ documentation for specific setup configurations.

Sound card out

Sound card in

Mixer out

Mixer in

Mixer

Digital card
Digital in

Digital out

MIDI card

Sync. in

Sync. out

The dashed line indicates
an option if you are synching
Vegas Pro to tape via a 
MIDI Time Code. MTC converter

Digital
multitrack
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Starting and stopping recording

Whether you are recording into an empty track, a selected event, or a time selection, you 
need to prepare the track(s) for record by clicking the Arm for Record ( ) button before 
any new data is created. Once a track is armed, you will see a record meter appear on the 
track(s) to be recorded into.

 

To start recording, click the Record button ( ) on the Transport bar, which is located just 
below the Track View. 

Depending on the recording selection, you will see Vegas Pro create a waveform along the 
timeline as you record into the armed track(s).

To stop recording, click the Record button ( ) again or the Stop button ( ) on the 
Transport bar. A dialog will appear giving you the opportunity to rename, delete, or keep the 
*.wav file. 

Track is ready for recording Arm the track first

Start/stop Stop recording
recording

Recorded waveform

Delete—removes selected file

Rename—changes the name of a selected file

Delete All—removes all files in dialog

Done—returns to Track View

When a check mark appears in this box,
Vegas Pro will display this dialog after
each recording session.
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Recording into an empty track

Whether your project is new or already contains tracks, you may record into an empty track. 
As you record, Vegas Pro will create the event’s waveform that will display on the track. The 
event, like all events in your project, will have a source media file. By default, Vegas Pro 
stores recorded media files in the Vegas Pro program folders. However, you may specify 
where recorded media files are stored. For more information, see Specifying where recordings are 
stored on page 153.

On the Track View, the cursor position is where recording will begin. You may want to place 
the cursor along the timeline before you record. Positioning the cursor is not always 
necessary since you may move the event after recording.

To record into an empty track, do the following:

1. Press the  keys to insert an empty track.

Or, from the Insert menu, choose Audio Track.

2. Place the cursor on the timeline where you want to begin recording.

3. Select the track that you want to record into.

Note: To select multiple tracks, click them while 
holding down either the  key to select adjacent 
tracks, or the  key to select random tracks.

4. Arm the selected track(s) by clicking the Arm for Record button ( ) on the track(s).

5. Start recording by clicking the Record button ( ) on the Transport bar. 

Recording will begin at the cursor's position and continue along the timeline until you stop 
recording. 

Ctrl + Q

Shift
Ctrl
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Recording into a time selection

By making a time selection, you specify where along the timeline to record. Also, the time 
selection determines how long Vegas Pro will record. Any selected events that occur within 
the time selection will be split, and the recorded data will be placed into the time selection. 
For more information, see Recording into an event with a time selection on page 147.

The recorded event, like all events in your project, will have a source media file. By default, 
Vegas Pro stores recorded media files in the Vegas Pro program folder. However, you may 
specify where recorded media files are stored. For more information, see Specifying where 
recordings are stored on page 153.

To record into a time selection, do the following:

1. Click the Arm for Record button ( ) on the desired track.

Note: To select multiple tracks, click them while 
holding down either the  key to select adjacent 
tracks, or the  key to select random tracks.

2. On the Marker bar, click and drag to make the time selection. You may adjust the time 
selection by dragging the selection bar’s starting and ending points.

3. Click the Record button ( ) on the Transport bar to begin recording.

Vegas Pro will display the event’s waveform as it is recorded and automatically stop 
recording when the cursor reaches the end of the time selection.

To record multiple takes, click the Loop play ( ) button on the Transport bar. For more 
information, see Working with multiple recorded takes on page 148.

Shift

Ctrl

Time selection bar

Start recording

Recorded waveform

Loop play
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Recording into an event

You may record directly into an event. By recording into an event, you specify where along 
the timeline to record and for how long. The edges of the selected event serve as the punch-
in and -out points that Vegas Pro uses for recording. One advantage to recording into an 
event is that you can establish pre-roll before recording. Pre-roll gives you time to prepare 
before recording starts.

The existing event that you record into is not affected or deleted. It will be listed as a take 
“under” the recorded event. For more information, see Working with multiple recorded takes on 
page 148. After you record into an event, the recorded waveform appears on the track.

The recorded event, like all events in your project, will have a source media file. By default, 
Vegas Pro stores recorded media files in the Vegas Pro program folder. However, you may 
specify where recorded media files are stored. For more information, see Specifying where 
recordings are stored on page 153.

To record into a selected event, do the following:

1. Place the cursor before the event to allow for pre-roll.

2. Press the  key and click the event to select it.

Note: You may select multiple events and 
record into them. Hold down  key and 
make your selections.

3. Click the Arm for Record button ( ) on the event’s track. If you are recording into 
multiple selected events, arm their respective tracks.

4. Click the Record button ( ) on the Transport bar to begin recording.

Vegas Pro will display the event’s waveform as you record.

5. Click the Record button ( ) or the Stop button ( ) on the Transport bar to stop 
recording.

Ctrl

Selected Non-selected
eventevent

Ctrl

Stop recording
recording
Start/Stop
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Recording into an event with a time selection

You may record into a selected event within a time selection. This option allows you to add 
for pre- and post- roll during recording. The time selection is adjustable to increase or 
decrease the pre- and post-roll. During recording, the selected event’s edges serve as the 
punch-in and -out points. 

You may need to split an existing event into three pieces so that you can select a smaller 
portion of the event to record into. For more information, see Splitting events on page 94.

To record into an event with a time selection, do the following:

1. Click the Arm for Record button ( ) on the desired track(s).

2. Select the event to record into.

Note: You may select multiple events and 
record into them. Hold down  key and 
make your selections.

3. On the Marker bar, click and drag to make the time selection. You may adjust the time 
selection by dragging the selection bar’s starting and ending points.

To record multiple takes, click the Loop play ( ) button on the Transport bar. For more 
information, see Working with multiple recorded takes on page 148.

4. Click the Record button ( ) on the Transport bar to begin recording.

Note: You may create multiple punch-in and 
-out points by selecting more events within the 
time selection.

Ctrl

Pre-roll Post-roll

Time selection bar

Punch-in Punch-out
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Working with multiple recorded takes

If you made a time selection during recording, clicking the Loop Play ( ) button on the 
Transport bar will enable you to continually create takes during recording. Takes are 
different versions of a recorded event that you may play back and edit. 

During recording, Vegas Pro continually “loops” back to the beginning of the time selection 
and starts recording a new take until you stop recording. After you are done recording takes, 
you can preview, choose a new active, rename, and delete them.

Previewing takes

Vegas Pro allows you to view a list of takes and preview them before placing them in your 
project. The takes are listed from the selected event in which the takes were recorded.

To preview takes, do the following:

1. Select the event in which multiple takes were recorded.

2. Right-click to display a shortcut menu. 

Or, from the Edit menu, choose Takes to display a sub-menu.

3. Select Choose Active... from the sub-menu. The Take Chooser dialog appear.

4. Select the take that you want to preview and use the Play ( ) and Stop ( ) buttons 
within the dialog. 

5. To use a take, select it and click the OK button or double-click the take that you want to 
use. The selected take is now the active take.

The event take will be displayed as the active take on the track in your project.

Play Stop
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Choosing an active take after loop recording

As an alternative to the previous section, you may select an active take using the shortcut 
menu. After you have recorded multiple takes, the take that appears on the Track View is 
called the active take. The active take is the last one which you recorded. You may make a 
previous recorded take the active one so that it will play back.

To select new active take, do the following:

1. Select the event into which multiple takes were recorded.

2. Right-click to display a shortcut menu. 

3. From the shortcut menu, choose Take. A sub-menu will appear with the event’s original 
file name (in this example, GuitarIntro) followed by the recorded takes, which are 
numbered sequentially. The active take will have a bullet next to it.

Note: This listing of the original event and 
takes “rotate” as you make different takes 
active.

4. Select the take that you want to make active by clicking it.

Note: You may give takes more meaningful 
names by changing the event’s name. For more 
information, see Renaming an event take on 
page 150.

Original event name

List of takes

Selected take
(take appearing in the project)
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Renaming an event take

Vegas Pro names recorded takes by specifying the track number and the take number, for 
example, Track 2 Recording 24 Take 2. These take names are specific to your project, but are not 
descriptive of what sound(s) were recorded. You may rename each take and give them more 
meaningful descriptions for easier reference while working on your project. 

You may only rename the active take name. For more information, see Choosing an active take 
after loop recording on page 149.

To rename an event take, do the following:

1. Click the recorded event to select it. The event being displayed is the active take.

2. Right-click on the selected event to display a shortcut menu.

3. From the shortcut menu, choose Rename Active. The take’s name will appear in a text box 
in the lower-left portion of the event. The event’s take name will be selected.

4. Type a new name in the text box.

5. Press the  key to save the new take name or click outside the text box.

Repeat steps 1-5 to rename the other takes in the event. Remember to make a take active 
before renaming it.

Note: You may also change event names via 
the event’s properties. For more information, 
see Changing the active take’s name on page 
102.

Before take rename After take rename

Enter
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Deleting an event take

Vegas Pro allows you delete unwanted recorded takes from your project. Deleting a take does 
not remove the event takes source file. You need to manually remove unwanted media 
source files that were recorded. By removing unwanted media source files that were 
recorded, you will save on disk space. For more information, see Using the Explorer window on 
page 165.

There are two ways to delete event takes: deleting the active take and deleting takes from a 
list. 

Deleting the active take

The active take is the event that appears on the Track View. If the event take you want to 
remove is not displayed, make it the active take before deleting it. For more information, see 
Choosing an active take after loop recording on page 149.

To delete the active take, do the following:

1. Click on the event take to select it.

2. Right-click on the event take to display a shortcut menu.

3. From the shortcut menu, choose Takes and then Delete Active from the sub-menu. 

Or, from the Edit menu, choose Takes and then Delete Active from the sub-menu.

The event take will be removed, and if there are multiple takes, the next take will appear on 
the Track View.
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Deleting event takes from a list

You may delete takes from a list when you have chosen the one that you want to use in your 
project. You may delete multiple event takes at a time.

To delete event takes from a list, do the following:

1. Click on the event take to select it.

2. Right-click on the event to display a shortcut menu.

3. From the shortcut menu, choose Takes and then Delete from the sub-menu. The Delete 
Takes dialog will appear.

Or, from the Edit menu, choose Takes and then Delete from the sub-menu. The Delete 
Takes dialog will appear.

4. Select the event take that you want to remove. Click the play button to confirm that the 
selected event is the one you want to remove. 

Note: To select multiple event takes, hold 
down either the  or  keys.

5. Click the OK button to remove the selected event take(s) from your project. 

Play Stop

Shift Ctrl
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Specifying where recordings are stored

Vegas Pro is a non-destructive audio editing environment. Events within your project are 
actually references to media source files located on a storage device such as a hard drive or 
CD-ROM. When you record into Vegas Pro, the event appears on the Track View while its 
media source file is written to your hard drive. By default, Vegas Pro stores recorded media 
source files in the Vegas Pro program folder. However, you may specify where Vegas Pro 
writes and stores recorded media source files.

To change where recorded media source files are stored, do the following:

1. From the File menu, choose Properties or press the  shortcut keys. The Project 
Properties dialog will display.

2. Click the Audio tab to display the projects audio properties.

Alt + Enter

Path where recorded
media source files are 
written and stored. Also,
available disk space.
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3. Click the Browse button. The Recorded Files Folder dialog will appear.

4. Navigate to the hard drive or folder where you want Vegas Pro to write and store recorded 
media source files.

5. Click the Save button to set the destination drive or folder.

Click the Cancel button leave the current destination the same.

6. Repeat steps 1-4 to change the destination again.

Note: Check Start all new projects with these 
settings if you want new projects to store 
recorded media source files to the same 
location. Otherwise, Vegas Pro will use its 
default settings.
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8

Track and 
Assignable FX
Vegas supports DirectX Audio plug-ins. Therefore, all of the DirectX Audio plug-ins, 
available from Sonic Foundry, or any other company will be available to use in your Vegas 
Pro project.

Track FX

Vegas Pro allows to you use the built-in Noise Gate, EQ, and Compression plug-ins on the 
tracks in any order. Standard DirectX Plug-ins can not be added to the tracks. To use 
standard DirectX plug-ins, use the Assignable FX or Bus FX. This information is discussed 
later in this chapter. 

To add track FX, do the following:

1. Click on the Track FX button ( ) on the track to which you want to add FX. The FX 
dialog appears.

2. Adjust the settings for the FX and click the OK button. 

Click on the help button ( ), within the FX dialog, for information on specifying these 
settings.

Bypass effect
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Plug-in Chooser

The Plug-in Chooser window allows you to create, organize, and rename the plug-ins 
compatible with Vegas Pro. You may access the Plug-in Chooser via the Insert menu, 
Assignable FX Control, and the Bus Control. The Assignable FX Control, which appears 
after you create a chain, and the Bus Control display in the Mixer window.

Click the FX button
to edit the chain’s 

Click the chain’s
FX button edit

settings the chain

Click the bus
FX button
to add a 
chain

Note: Buses with chains already
assigned will work similar to the
FX chain in this example: the bus’s 
 FX settings will appear whenchain

Mixer

.you click its FX button.
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Creating an Assignable FX chain

You create plug-in chains in the FX Plug-in Chooser dialog. After you create the chain, an 
Assignable FX Control will appear in the Mixer window.You can create up to 32 plug-in 
chains in your project and each chain can have up to 32 plug-in FX.

To create a plug-in chain, do the following:

1. From the Insert menu, choose Assignable FX. The FX Plug-In Chooser dialog will appear.

2. Double-click on a plug-in to add it to the chain. Or, select the plug-in and click on the 
Add button. 

The plug-ins appear at the bottom of the dialog in the order they were added. To reorder 
the plug-ins within the chain, click on the a plug-in and drag it to the new position or 
click the appropriate reorder button in the lower-right corner of the chooser dialog. 

3. When you are finished, click the OK button. The new Assignable FX Control is added to 
the Mixer window and the FX dialog appears.

4. Adjust the settings for the FX. Click on the help button ( ) within the FX dialog for 
information on specifying these settings.

Move the selected
chain FX’s position

Chain’s order 
of FX

Bypass Navigate 

Mute Solo

Float chain

the chaineffect
Assignable
FX

Mixer
window
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Assignable FX Control

Assignable FX Controls appear, along with the Bus Controls, in the Mixer window. This 
control is created for each Assignable FX chain that you have added to your project.

Saving Assignable FX as presets

You can save an Assignable FX chain settings as a preset for use in another project.

To save an Assignable FX chain as a preset, do the following:

1. Click on the Assignable FX button ( ) on the Assignable FX Control. The FX dialog 
appears.

2. In the FX dialog, click on the Assignable FX chain button ( ). The Plug-in chooser 
dialog appears.

Mute Mutes the Assignable FX

Master Fader Adjusts the volume of the Assignable FX

Solo Plays only the output of that Assignable FX chain

Assignable FX chain Displays the Plug-in chooser and allows you to adjust the Assignable FX attributes

Meter Displays the playback level of the Assignable FX

Scribble Strip Allows you to name the Assignable FX. Double click on the Scribble Strip to enter a name

Mute

Solo

Assignable FX chooser

Scribble Strip

Input
Master
Fader

Output
Master
Fader

Bus assignment

Meter
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3. Click on the FX Plug-in Chooser’s Save As button. The Save Plug-in Chain dialog will 
appear.

4. Enter a name in the Save Plug-in Chain as dialog. 

5. Click the OK button and the preset will be saved to the FX Chain folder in the Plug-in 
Chooser dialog.

Editing an Assignable FX chain

You may add or delete plug-ins, change the order of your plug-in chain, or change any of the 
Assignable FX attributes after you have created the Assignable FX chain.

Click on the Assignable FX chain button ( ) on the Assignable FX Control in the Mixer 
window.

Routing tracks to an Assignable FX chain

You may assign tracks to an Assignable FX chain. Vegas Pro allows you to use a single plug-
in on multiple tracks. For example, if you wanted to use the same reverb sound on several 
tracks, you could create a single Assignable FX chain and route the tracks to it in whatever 
mix you like.

The Assignable FX chains that you have created appear in the Mixer window as individual 
Assignable FX Controls. 

To route a track to an Assignable FX, do the following:

1. Expand the track so that you see the Multipurpose slider. For more information, see 
Expanding an individual track on page 128.

2. Click on the Multipurpose slider’s label. Select the desired Assignable FX from the sub-
menu. The label name changes to reflect the name of the Assignable FX.

Assignable
FX chain

Multipurpose slider label
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3. Use the Multipurpose slider to adjust the volume level that the track sends to the 
Assignable FX chain. 

The Master Input Fader on the FX control can be used to adjust the combined level of all 
tracks being sent into the plug-in chain. It is important to remember that in most cases you 
will want to set the wet/dry levels inside the plug-ins to 100% wet. You can then control the 
wet/dry balance between the main track outputs and Assignable FX outputs using the 
Master Output Fader on the FX control. For more information, see Assignable FX Control on 
page 158.

Removing an Assignable FX

After you have created Assignable FX chains, you may remove them from your project at 
any time. When you remove an FX chain, it is deleted from the project. You must recreate 
the FX chain if you want to use it again. If you want to keep the chain, but do not want to 
use it in your current project, you may save the chain as a preset. For more information, see 
Saving Assignable FX as presets on page 158.

To remove an Assignable FX chain from your project, do the following.

1. From the Insert menu, choose Remove Assignable FX. The Remove Effect(s) dialog will 
appear.

2. Select the FX or plug-in chain that you want to remove. To remove more than one item, 
hold down the  key while clicking on the FX or plug-in chain. 

3. Click on the OK button. The FX chain is removed from the project and its Assignable FX 
Control is removed from the Mixer window.

Multipurpose slider

Ctrl
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Assigning FX to Busses

Along with assigning FX to individual tracks, you may also assign FX to busses. Any changes 
to Bus FX settings will affect all tracks assigned to that bus. If track FX (EQ or compression) 
exist and the track is assigned to a bus with FX, the track’s signal will flow through the track 
FX before the Bus FX. For more information, see Signal Flow on page 25.

Assigning FX to Busses

1. Click on the Bus FX button ( ), which is located in the Mixer window. The FX Plug-in 
Chooser dialog appears.

2. Double-click on a plug-in to add it to the chain. Or, select the plug-in and click on the 
Add button.

3. When you have finished adding the plug-ins, click on the OK button.

Click the bus’s
FX button
to add a 
chain

Mixer
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Troubleshooting
Why are some of my DirectX plug-ins not working correctly?

Vegas Pro is a non-destructive time-based editor. As a result, there are certain types of 
DirectX Plug-ins that perform poorly in Vegas Pro as Assignable FX or Bus FX. These types 
of plug-ins are roughly classified as any plug-in that outputs a different amount of time than 
what goes in. This includes all plug-ins like time compress/expand, gapper/snipper and pitch 
shift without preserving duration. However, these types of FX plug-ins may perform suitably 
as Bus FX, but only if one bus is used in the project.

In addition, plug-ins that require a lot of pre-buffering will also perform poorly such as Sonic 
Foundry Acoustic Mirror when using long impulse files.

Why do I hear gaps in my audio playback?

There are many reasons that your audio playback can gap. 

• Playing back more simultaneous tracks than your hard drives can handle
• Running out of physical RAM can cause Windows to start using virtual memory
• Running too many DirectX plug-ins can use up all your computer’s power 
• Having sound card driver problems can cause play back gapping

Below are a things you can check and do to make sure your system is optimized to prevent 
gapping.

RAM usage meter

If the RAM usage meter at the bottom of the Vegas Pro Track View indicates that most of 
your physical RAM is in use, you could be gapping because Windows virtual memory is 
being used. Virtual memory is a method used by Windows to write information to your hard 
drive to make room in physical RAM. This process uses a lot of your computer’s resources.

RAM usage meter
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To minimize the amount of RAM that you are using, try the following:

1. Exit all background applications not in use.

2. Adjust the playback buffering slider on the Preferences’ Audio tab.

Adjust this slider as low as possible, but setting it too low will cause gaps as well.

3. Run fewer events simultaneously by muting or soloing them.

4. Add more RAM to your computer. However, after 128 MB, the performance increase that 
you get will start to decline.

Disk meter

If the Disk meter at the bottom of the Track View ever bounces near or above 50%, you will 
probably experience gapping. This issue is due to the data not being read off the hard drive 
fast enough.

To optimize the reading of data off the hard drive, try the following:

1. Fully defragment your audio hard drives regularly.

2. Split audio usage between different physical hard drives, not just different partitions of 
the same drive.

3. Run fewer events simultaneously. It is not how many tracks you have in the project, but 
how many different events are playing simultaneously that matters. 

4. Make sure that you trim out any silent sections of events to minimize the wasted disk 
access.

5. Use hard drives with fast seek times and spindle speeds of 7200 RPM or greater. SCSI 
drives have better prolonged data transfer performance than IDE drives.

Disk usage meter
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CPU usage

If neither the RAM or Disk meter looks out of the ordinary, you can try to adjust how Vegas 
Pro utilizes the central processing unit (CPU).

To optimize CPU usage, try the following:

1. If you are using video, turn off the Animate video strip option on the Preferences’ General 
tab. 

2. Zoom out (  + ) fully on the Track View while playing so that the screen does not 
have to scroll to keep the cursor on it.

3. Run fewer DirectX plug-ins.

4. Make sure that the peak files are built for all of the audio data in the project before 
playing. Peaks are only built for those files on screen so you can get into the situation 
where the screen scrolls and it ends up building a peaks on-the-fly. You can play while 
peaks are being built, but on a CPU bound machine, it will gap for sure.

Why can't I get my other DirectX plug-ins to work as Track effects?

This version of Vegas Pro has a special DirectX interface at the track level. It means that 
only DirectX plug-ins with a special wrapper will work in that position. The Track EQ, 
Compressor and Dither plug-ins will work there.

MPEG and Quicktime Video Audio/Video Synchronization Issues

Vegas Pro is able to open MPEG and Quicktime audio/video files that were encoded using 
Microsoft DirectShow codecs. However, there is an implementation issue that causes the 
audio and video to fall out of sync with each other. This happens frequently and it is not 
consistent in its offset. Therefore, this issue makes working with these types of files 
troublesome. 

We are working to correct this issue for future versions of Vegas Pro. In the meantime, a 
work around is to separately save out the video and audio portions of the files into AVI and 
Wave files, respectively. After that, you can reload them into Vegas Pro, re-synchronize 
them and the synchronization will stay constant.

Ctrl
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Some AVI's that open in Windows Media Player don't open in Vegas Pro

Some newer AVI files use codecs that are unreadable by applications that do not support 
Microsoft DirectShow codecs. These files are usually either compressed with a DV or MPEG 
4 codec. They might also be larger than the standard AVI file limit of 4 Gigabytes.Vegas Pro 
does not currently support these files.

Why does a mono event increase 6 dB when panning a track hard to either 
side?

In Vegas Pro, all audio events on tracks is stereo. So, a mono-audio event is interpreted as a 
stereo event with the same data in both channels. The Vegas Pro track-pan control 
preserves some amount of stereo separation when panning a stereo signal and gradually 
mixes the level from channel to channel. Therefore, with a mono-audio event, Vegas Pro is 
adding a duplicate of the event on top of itself. This duplication doubles the amplitude and 
results in a 6 dB increase in volume when you pan a track hard left or right. To compensate 
for this increase, adjust the tracks volume with the fader. Or, lower the event’s sustain 
portion using an event envelope (ASR). For more information, see Using event envelopes 
(ASR) on page 110.
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Glossary
A-Law

A companded compression algorithm for voice signals defined by the Geneva 
Recommendations (G.711). The G.711 recommendation defines A-Law as a method of 
encoding 16-bit PCM signals into a non-linear 8-bit format. The algorithm is commonly 
used in United States’ telecommunications. A-Law is very similar to µ-Law, however, each 
uses a slightly different coder and decoder.

Adaptive Delta Pulse Code Modulation (ADPCM)

A method of compressing audio data. Although the theory for compression using ADPCM is 
standard, there are many different algorithms employed. For example, Microsoft’s ADPCM 
algorithm is not compatible with the International Multimedia Association’s (IMA) 
approved ADPCM.

Aliasing

A type of distortion that occurs when digitally recording high frequencies with a low sample 
rate. For example, in a motion picture, when a car’s wheels appear to slowly spin backward 
while the car is quickly moving forward, you are seeing the effects of aliasing. Similarly, 
when you try to record a frequency greater than one-half of the sampling rate (the Nyquist 
Frequency), instead of hearing a high pitch, you may hear a low-frequency rumble.

To prevent aliasing, an anti-aliasing filter is used to remove high-frequencies before 
recording. Once the sound has been recorded, aliasing distortion is impossible to remove 
without also removing other frequencies from the sound. This same anti-aliasing filter must 
be applied when resampling to a lower sample rate.

Amplitude Modulation (AM)

A process whereby the amplitude (loudness) of a sound is varied over time. When varied 
slowly, a tremolo effect occurs. If the frequency of modulation is high, many side frequencies 
are created which can strongly alter the timbre of a sound.
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Analog

When discussing audio, this term refers to a method of reproducing a sound wave with 
voltage fluctuations that are analogous to the pressure fluctuations of the sound wave. This 
is different from digital recording in that these fluctuations are infinitely varying rather than 
discrete changes at sample time (see Quantization).

Attack

The attack of a sound is the initial portion of the sound. Percussive sounds (drums, piano, 
guitar plucks) are said to have a fast attack. This means that the sound reaches its maximum 
amplitude in a very short time. Sounds that slowly swell up in volume (soft strings and wind 
sounds) are said to have a slow attack.

Audio Compression Manager (ACM)

The Audio Compression Manager, from Microsoft, is a standard interface for audio 
compression and signal processing for Windows. The ACM can be used by Windows 
programs to compress and decompress *.wav files.

Bandwidth

Refers to the EQ plug-in that is built in. Each frequency band has a width associated with it 
that determines the range of frequencies that are affected by the EQ. An EQ band with a 
wide bandwidth will affect a wider range of frequencies than one with a narrow bandwidth.

Beats Per Measure (BPM)

In music theory, the time signature of a piece of music contains two pieces of information: 
the number of beats in each measure of music, and which note value gets one beat. Vegas 
Pro uses this notion to determine the number of ticks to put on the Time ruler above the 
Track View, and to determine the spacing when the ruler is displaying Measures & Beats.

Beats Per Minute

In music theory, the tempo of a piece of music can be written as a number of beats in one 
minute. If the tempo is 60 BPM, a single beat occurs once every second. Lower BPM’s equal 
slower tempo, and vice versa.

Bit

A bit is the most elementary unit in digital systems. Its value can only be 1 or 0, 
corresponding to a voltage in an electronic circuit. Bits are used to represent values in the 
binary numbering system. As an example, the 8-bit binary number 10011010 represents the 
unsigned value of 154 in the decimal system. In digital sampling, a binary number is used to 
store individual sound levels, called samples.
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Bit Depth

The number of bits used to represent a single sample. Vegas Pro uses either 8, 16, or 24-bit 
samples. Higher values will increase the quality of the playback and any recordings that you 
make. While 8-bit samples take up less memory (and hard disk space), they are inherently 
noisier than 16 or 24-bit samples.

Byte

Refers to a set of 8 bits. An 8-bit sample requires one byte of memory to store, while a 16-bit 
sample takes two bytes of memory to store.

Clipboard

The clipboard is where data that you have cut or copied in Vegas Pro is stored. You can then 
paste the data back into Vegas Pro at a different location, or paste it into other applications, 
such as Microsoft Word, or another instance of Vegas Pro. Some data, such as audio, cannot 
be pasted into applications such as Microsoft Word or Notepad, but the text data from the 
Edit Details window can be pasted. This allows you to then print or format the data.

Clipping

Clipping is what occurs when the amplitude of a sound is above the maximum allowed 
recording level. In digital systems, clipping is seen as a clamping of the data to a maximum 
value, such as 32,767 in 16-bit data. Clipping causes sound to distort.

CODEC

An acronym for Coder/Decoder that is commonly used when working with data 
compression.

Crossfade

Mixing two pieces of audio by fading one out as the other fades in.

Cutoff frequency

The cutoff-frequency of a filter is the frequency at which the filter changes its response. For 
example, in a low-pass filter, frequencies greater than the cutoff frequency are attenuated 
while frequencies less than the cutoff frequency are not affected.

DC Offset

DC Offset occurs when hardware, such as a sound card, adds DC current to a recorded audio 
signal. This current causes the audio signal to alternate around a point above or below the 
normal -infinity dB (center) line in the sound file. To visually see if you have a DC offset 
present, you can zoom all the way into a sound file and see if it appears to be floating over 
the center line.
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Decibel (dB)

A unit used to represent a ratio between two numbers using a logarithmic scale. For 
example, when comparing the numbers 14 and 7, you could say 14 is two times greater than 
the number 7; or you could say 14 is 6 dB greater than the number 7. Where did we pull that 
6 dB from? Engineers use the equation dB = 20 x log (V1/V2) when comparing two 
instantaneous values. Decibels are commonly used when dealing with sound because the ear 
perceives loudness in a logarithmic scale.

In Vegas Pro, most measurements are given in decibels. For example, if you want to double 
the amplitude of a sound, you apply a 6 dB gain. A sample value of 32,767 (maximum 
positive sample value for 16-bit sound) can be referred to as having a value of 0 dB. 
Likewise, a sample value of 16,384 can be referred to having a value of -6 dB.

Device Driver

A program that enables Windows to connect different hardware and software. For example, 
a sound card device driver is used by Windows software to control sound card recording and 
playback.

Digital Signal Processing (DSP)

A general term describing anything that alters digital data. Signal processors have existed for 
a very long time (tone controls, distortion boxes, wah-wah pedals) in the analog (electrical) 
domain. Digital Signal Processors alter the data after it has been digitized by using a 
combination of programming and mathematical techniques. DSP techniques are used to 
perform many effects such as equalization and reverb simulation.

Since most DSP is performed with simple arithmetic operations (additions and 
multiplications), both your computer’s processor and specialized DSP chips can be used to 
perform any DSP operation. The difference is that DSP chips are optimized specifically for 
mathematical functions while your computer’s microprocessor is not. This results in a 
difference in processing speed.

Dithering

The practice of adding noise to a signal to mask quantization noise.

Drag and Drop

A quick way to perform certain operations using the mouse in Vegas Pro. To drag and drop, 
you click and hold a highlighted selection, drag it (hold the left-mouse button down and 
move the mouse) and drop it (let go of the mouse button) at another position on the screen.
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 Dynamic Range

The difference between the maximum and minimum signal levels. It can refer to a musical 
performance (high volume vs. low volume signals) or to electrical equipment (peak level 
before distortion vs. noise floor). For example, orchestral music has a wide dynamic range, 
while thrash metal has a very small (always loud) range.

Endian (Little and Big)

Little and Big Endian describe the ordering of multi-byte data that is used by a computer’s 
microprocessor. Little Endian specifies that data is stored in a low to high-byte format; this 
ordering is used by the Intel microprocessors. Big Endian specifies that data is stored in a 
high to low-byte format; this ordering is used by the Motorola microprocessors. 

Envelopes (Audio and Video)

Envelopes, as used by Vegas Pro, are a way of automating the change of a certain parameter 
over time. In the case of Volume, you can create a fade out (which requires a change over 
time) by adding an envelope and creating an extra point to the line that indicates where the 
fade starts. Next, you pull the end point of the envelope down to infinity.

Equalization (EQ)

The process by which certain frequency bands are raised or lowered in level. EQ has various 
uses. The most common use for Vegas Pro users is to simply adjust the subjective timbral 
qualities of a sound.

Event

A media file that has been placed into a Vegas Pro project. The media file is placed on a 
track or the video ruler and plays back as an audio or video “event” along the project’s 
timeline.

File Format

A file format specifies the way in which data is stored on your floppy disks or hard drive. In 
Windows, the most common file format is the Microsoft *.wav format. However, Vegas Pro 
can read and write to many other file formats so you can maintain compatibility with other 
software and hardware configurations.

Frame Rate (Audio)

Audio uses frame rates only for the purposes of synching to video or other audio. In the latter 
case, the rate of 30 non-drop is typically used. In the former case, 30 drop is usually used.
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Frame Rate (Video)

The speed at which individual images in the video are displayed on the screen. A faster 
frame rate results in smoother motion in the video. However, more times than not, frame 
rate is associated with SMPTE standard frame rates for video: 29.97, 25 or 24 for film.

Frequency Spectrum

The Frequency Spectrum of a signal refers to its range of frequencies. In audio, the frequency 
range is basically 20 Hz to 20,000 Hz. The frequency spectrum sometimes refers to the 
distribution of these frequencies. For example, bass-heavy sounds have a large frequency 
content in the low end (20 Hz - 200 Hz) of the spectrum.

Hertz (Hz)

The unit of measurement for frequency or cycles per second (CPS).

Insertion Point

The Insertion Point (also referred to as the Cursor Position) is analogous to the cursor in a 
word processor. It is where pasted data is placed or other data is inserted, depending on the 
operation. The Insertion Point appears as a vertical flashing black line and can be moved by 
clicking the left mouse button any where in the waveform display of a data window. 

Markers

Saved locations in the sound file. Markers are stored in the Regions List and can be used for 
quick navigation.

Markers can be displayed in the Trimmer window for sound files that contain them, but 
more often, markers and regions are used at the project level to mark interesting places in 
the project. 

Media Control Interface (MCI)

A standard way for Windows programs to communicate with multimedia devices like sound 
cards and CD players. If a device has a MCI device driver, it can easily be controlled by most 
multimedia Windows software.

Media Player

A Microsoft Windows program that can play digital sounds or videos using MCI devices. 
Media Player is useful for testing your sound card setup. For example, if you can’t hear sound 
when using Vegas Pro, try using Media Player. If you can’t play sound using Media Player, 
check the sound card’s manual. Please contact your sound card manufacturer before calling 
Technical Support at Sonic Foundry.
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MIDI Clock

A MIDI device specific timing reference. It is not absolute time like MIDI Time Code 
(MTC); instead, it is a tempo-dependent number of “ticks” per quarter note. MIDI Clock is 
convenient for syncing devices that need to do tempo changes mid-song. Vegas Pro supports 
MIDI Clock out, but does not support MIDI Clock in.

MIDI Port

A MIDI Port is the physical MIDI connection on a piece of MIDI gear. This port can be a 
MIDI in, out or through. Your computer must have a MIDI to output MIDI Time Code to an 
external device or to receive MIDI Time code from an external device.

MIDI Time Code (MTC)

MTC is an addendum to the MIDI 1.0 Specification and provides a way to specify absolute 
time for synchronizing MIDI capable applications. Basically, it is a MIDI representation of 
SMPTE time code.

Mix

A function Vegas Pro performs inherently by adding events to multiple audio tracks.

Multiple Stereo

A Mixer configuration that allows you to assign individual tracks to any number of stereo 
output busses. In single stereo mode, all tracks go out the same stereo bus. Multiple stereo 
configuration allows you to keep your signals from the Tracks discrete if you want them to 
be.

Musical Instrument Device Interface (MIDI)

A standard language of control messages that provides for communication between any 
MIDI compliant devices. Anything from synthesizers to lights to factory equipment can be 
controlled via MIDI. Vegas Pro utilizes MIDI for synchronization purposes.

Noise-shaping

Noise-shaping is a technique which can minimize the audibility of quantization noise by 
shifting its frequency spectrum. For example, in 44,100 Hz audio, quantization noise is 
shifted towards the Nyquist Frequency of 22,050 Hz.

Non-Destructive Editing

This type of editing involves a pointer-based system of keeping track of edits. When you 
delete a section of audio in a non-destructive system, the audio on disk is not actually 
deleted. Instead, a set of pointers is established to tell the program to skip the deleted section 
during playback.
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Normalize

Refers to raising the volume so that the highest level sample in the file reaches a user-
defined level. Use this function to make sure you are fully utilizing the dynamic range 
available to you.

Nyquist Frequency

The Nyquist Frequency (or Nyquist Rate) is one-half of the sample rate and represents the 
highest frequency that can be recorded using the sample rate without aliasing. For example, 
the Nyquist Frequency of 44,100 Hz is 22,050 Hz. Any frequencies higher than 22,050 Hz 
will produce aliasing distortion in the sample if no anti-aliasing filter is used while recording.

Pan

To place a mono or stereo sound source perceptually between 2 or more speakers.

Peak Data File

The file created by Vegas Pro when a file is opened for the first time. This file stores the 
information regarding the graphic display of the waveform, so that opening a file is almost 
instantaneous. The peak data file is stored in the directory in which the file resides and has a 
.sfk extension. If the peak data file is not in the same directory as the file, or is deleted, it will 
be recalculated the next time you open the file.

Plug-In

An effect that can be added to the product to enhance the feature set. Vegas Pro supports all 
DirectX plug-ins. The built-in EQ, Compression and Dithering effects are also considered 
plug-ins because they work in other DirectX-compatible applications.

Plug-In Chain

Plug-ins can strung together into a chain so that the output of one effect feeds into the input 
of another. This allows for complex effects that couldn’t otherwise be created.

Pre-roll/Post-roll

Pre-roll is the amount of time elapsed before an event occurs. Post-roll is the amount of time 
after the event. The time selection defines the pre- and post-roll when recording into a 
selected event.

Preset

A snapshot of the current settings in a plug-in. Presets are created and named so that you 
can easily get back to a sound that you have previously created.
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A preset calls up a bulk setting of a function in Vegas Pro. If you like the way you tweaked 
that EQ, but do not want to have to spend the time getting it back for later use, save it as a 
preset. All presets show up in the combo box on the top of most function dialogs in Vegas 
Pro.

Pulse Code Modulation (PCM)

PCM is the most common representation of uncompressed audio signals. This method of 
coding yields the highest fidelity possible when using digital storage.

Punch-In

Punching-in during recording means automatically starting and stopping recording at user-
specified times.

Quadraphonic

A mixing implementation that allows for four (4) discrete audio channels. These are usually 
routed to two (2) front speakers and two back speakers to create immersive audio mixes.

Quantization

The process by which measurements are rounded to discrete values. Specifically with respect 
to audio, quantization is a function of the analog-to-digital conversion process. The 
continuous variation of the voltages of a analog audio signal are quantized to discrete 
amplitude values represented by digital, binary numbers. The number of bits available to 
describe these values determines the resolution or accuracy of quantization. For example, if 
you have 8-bit analog-to-digital converters, the varying analog voltage must be quantized to 
1 of 256 discrete values; a 16-bit converter has 65,536 values.

Quantization Noise

A result of describing an analog signal in discrete digital terms (see Quantization). This 
noise is most easily heard in low resolution digital sounds that have low bit depths and is 
similar to a “shhhhh” type sound while the audio is playing. It becomes more apparent when 
the signal is at low levels, such as when doing a fade out.

Region

A subsection of a sound file denoted by a start and end point. You can define any number of 
regions in a sound file.

Resample

The act of recalculating samples in a sound file at a different rate than the file was originally 
recorded. If an audio file is resampled at a lower rate, Vegas Pro decreases sample points. As 
a result, the file size and the frequency range are reduced. Resampling to a higher sample 
rate, Vegas Pro will interpolate extra sample points in the sound file. This increases the size 
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of the sound file but does not increase the quality. When down-sampling, one must be aware 
of aliasing (see Aliasing). Vegas Pro automatically resamples all audio that is added to the 
project’s sample rate.

Ruler Tags

Small tab-shaped controls above the Time Ruler that represent the location of markers, 
regions, and loop points in the waveform display.

Ruler, Time

The Time Ruler is the area on a data window above the tracks display window that shows 
the horizontal axis units.

Sample

The word “sample” is used in many different (and often confusing) ways when talking about 
digital sound. Here are some of the different meanings:

• A discrete point in time which a sound signal is divided into when digitizing. For 
example, an audio CD-ROM contains 44,100 samples per second. Each sample is really 
only a number which contains the amplitude value of a waveform measured over time.

• A sound which has been recorded in a digital format; used by musicians who make short 
recordings of musical instruments to be used for composition and performance of music or 
sound effects. These recordings are called samples. In this manual, we try to use sound file 
instead of sample whenever referring to a digital recording.

The act of recording sound digitally, i.e. to sample an instrument, means to digitize and store 
it.

Sample Rate

The sample rate (also referred to as the sampling rate or sampling frequency) is the number 
of samples per second used to store a sound. High sample rates, such as 44,100 Hz provide 
higher fidelity than lower sample rates, such as 11,025 Hz. However, more storage space is 
required when using higher sample rates.

Sample Size

See Bit Depth.

Sample Value

The sample value (also referred to as sample amplitude) is the number stored by a single 
sample. In 16-bit audio, these values range from -32768 to 32767. In 8-bit audio, they range 
from -128 to 127. The maximum allowed sample value is often referred to as 100% or 0 dB.
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Shortcut Menu

A context-sensitive menu which appears when you click on certain areas of the screen. The 
functions available in the shortcut menu depend on the object being clicked on as well as 
the state of the program. As with any menu, you can select an item from the shortcut menu 
to perform an operation. Shortcut menus are used frequently in Vegas Pro for quick access to 
many commands. An example of a shortcut menu can be found by right-clicking on any 
waveform display in a data window.

Sign-Bit

Data that has positive and negative values and uses zero to represent silence. Unlike the 
Signed format, two’s complement is not used. Instead, negative values are represented by 
setting the highest bit of the binary number to one without complementing all other bits. 
This is a format option when opening and saving RAW sound files.

Signal-to-Noise Ratio

The signal-to-noise ratio (SNR) is a measurement of the difference between a recorded 
signal and noise levels. A high SNR is always the goal.

The maximum signal-to-noise ratio of digital audio is determined by the number of bits per 
sample. In 16-bit audio, the signal to noise ratio is 96 dB while in 8-bit audio it’s 48 dB. 
However, in practice this SNR is never achieved, especially when using low-end electronics.

Signed

Data that has positive and negative two’s complement values and uses zero to represent 
silence. This is a format option when opening and saving RAW sound files.

Small Computer Systems Interface (SCSI)

A standard interface protocol for connecting devices to your computer. The SCSI bus can 
accept up to seven devices at a time including CD ROM drives, hard drives and samplers.

Society of Motion Picture and Television Engineers (SMPTE)

SMPTE time code is used to synchronize time between devices. The time code is calculated 
in Hours:Minutes:Second:Frames, where Frames are fractions of a second based on the frame 
rate. Frame rates for SMPTE time code are 24, 25, 29.97 and 30 frames per second.

Sound Card

The sound card is the audio interface between your computer and the outside world. It is 
responsible for converting analog signals to digital and vice versa. There are many sound 
cards available on the market today covering the spectrum of quality and price. Vegas Pro 
will work with any Windows-compatible sound card.
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Stereo

Mixer implementation that includes 2 discrete channels.

Surround

Mixer implementation that includes 6 discrete channels.

Tempo

Tempo is the rhythmic rate of a musical composition, usually specified in Beats Per Minute 
(BPM).

Time Format

The format by which Vegas Pro displays the Time Ruler and selection times. These include: 
Time, Seconds, Frames and all Standard SMPTE frame rates. The status format is set for 
each sound file individually.

Time Signature

See Beats per Measure.

Track

A discrete timeline for audio data. Audio events sit on audio tracks and determine when a 
sound starts and stops. Multiple audio tracks are mixed together to give you a composite 
sound that you hear through your speakers.

Trim/Crop

A function that will delete all data in a sound file outside of the current selection. 

µ-Law

µ-Law (mu-Law) is a companded compression algorithm for voice signals defined by the 
Geneva Recommendations (G.711). The G.711 recommendation defines µ-Law as a 
method of encoding 16-bit PCM signals into a non-linear 8-bit format. The algorithm is 
commonly used in European and Asian telecommunications. µ-Law is very similar to A-Law, 
however, each uses a slightly different coder and decoder.

Undo Buffer

This is the temporary file created before you do any processing to a project. This undo buffer 
allows the ability to rewrite previous versions of the project if you decide you don’t like 
changes you’ve made to the project. This undo buffer is erased when the file is closed or the 
Clear Undo History command is invoked.
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Undo/Redo

These commands allow you to change a project back to a previous state, when you don’t like 
the changes you have made, or reapply the changes after you have undone them. The ability 
to Undo/Redo is only limited by the size of your hard drive. See Undo Buffer.

Undo/Redo History

A list of all of the functions that have been performed to a file that are available to be 
undone or redone. Undo/Redo History gives you the ability to undo or redo multiple 
functions as well as preview the functions for quick A/B-ing of the processed and 
unprocessed material. To display the history list, click the down-arrow button next to the 
Undo and Redo buttons.

Unsigned

Data that has only positive values and uses half the maximum value to represent silence. 
This is a format option when opening and saving RAW sound files.

Video for Windows (AVI)

A file format of digital video for Windows. Vegas Pro allows you to open .AVI files and edit 
the audio embedded within them.

Virtual MIDI Router (VMR)

A software-only router for MIDI data between programs. Vegas Pro uses the VMR to receive 
MIDI Time Code and send MIDI Clock. No MIDI hardware or cables are required for a 
VMR, so routing can only be performed between programs running on the same PC. Sonic 
Foundry supplies a VMR with Vegas Pro called the Sonic Foundry Virtual MIDI Router.

Waveform

A waveform is the visual representation of wave-like phenomena, such as sound or light. For 
example, when the amplitude of sound pressure is graphed over time, pressure variations 
usually form a smooth waveform.

Waveform Display

A section inside of the Trimmer window that shows a graph of the sound data waveform. 
The vertical axis corresponds to the amplitude of the wave. For 16-bit sounds, the amplitude 
range is -32,768 to +32,767. For 8-bit sounds, the range is -128 to +127. The horizontal axis 
corresponds to time, with the left-most point being the start of the waveform. In memory, 
the horizontal axis corresponds to the number of samples from the start of the sound file.
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Zero-crossing

A zero-crossing is the point where a fluctuating signal crosses the zero amplitude axis. By 
making edits at zero-crossings with the same slope, the chance of creating glitches is 
minimized.

Zipper noise

Zipper noise occurs when you apply a changing gain to a signal, such as when fading out. If 
the gain does not change in small enough increments, zipper noise can become very 
noticeable. Vegas Pro fades are accomplished using 64-bit arithmetic, thereby creating no 
audible zipper noise.
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Index
A

Activation code, 13

Active take, selecting, 149

Adding empty tracks, 123

Arm for Record, 36

ASR  See Envelopes

Assignable FX, 155–161
control, 158
creating a chain, 157
editing a chain, 159
plug-in chooser, 156
removing, 160
routing tracks to, 159
saving as presets, 158
tracks, 155

Audio files See Events

Auxiliary bus, 39
adding, 130
track assignment, 131
volume adjustment, 131

B

Bus assignment, 36

Busses
assigning to Assignable FX, 161

C

Color, tracks, 127

Command markers, 83
defined, 84
deleting, 87
editing, 86
moving, 85
naming, 86
navigating, 87
placing, 84

Computer ID number, 13

Converting format  See Rendering a project

Copying events, 67
time and events, 67
time selection, 67

Cross fades, 113–115
automatic, 113
curve types, 114
curve types, changing, 114
manually setting, 114
volume, changing, 115

Ctrl. key selecting, 64

Cursor, using, 63

Cutting events, 70–71
ripple mode, 96
time and event selection, 71

Cutting time and events
ripple mode, 97

Cutting time selection
ripple mode, 97
INDEX



ii
D

Deleting a track, 125

Deleting events, 73, 74
ripple mode, 98
time and event selection, 74
time selection, 73

Deleting time and events
ripple mode, 99

Deleting time selection
ripple mode, 98

Desktop shortcut, 12

Ditital multitrack setup, 142

Duplicating a track, 124

E

Edit history, clearing, 77

Edit tool, selection, 65

Editing
time vs. event, 64

Effects,  See Assignable FX

Email technical support, 10

Envelopes, 110–112
adding points, 133
event volume, 111
fade curve types, 112
fade in and out, 111
hiding panning on track, 138
panning fade curves, 137
setting points, 134
track, 132–138
volume fade curves, 134

EQ
adding, 59, 155

Equipment setup, 141–142
basic, 141
mixer, 142
with digital multitrack, 142
with MIDI option, 142

European contact information  Title page

Event editing, basics, 66–96

Event switches, 77–110
locking, 107
looping, 108
muting, 106
normalizing, 109

Event take
deleting, 151
renaming, 150

Event takes
deleting active, 151
deleting from list, 152

Event, recording into, 146

Events
copying, 67
cross fading, 113–115
cutting, 70
defined, 27
deleting, 73
editing, 54, 56
envelopes (ASR), 110
grouping, 57, 116–117
locking, 54
moving in time, 33
moving multiple, 34
moving single, 33
pasting, 68–70
placing, 31, 32, 52
properties, setting, 101
removing from video, 41
ripple edits, 96–100
selected vs. non-selected, 63
selecting, 63
selecting with time, 66
snapping, 91
splitting, 94
splitting with time selection, 55
trimming/cropping, 72

Expanding a track, 128

Explorer window, 20
transport bar, 30
using, 28, 50
view options, 29
INDEX
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F

Fader
auxiliary bus, 131
track, 128

Fax technical support, 11

FX send, 39

G

Glossary, 167–180

Grid lines
changing type, 92
enable/disable snapping, 92
snapping events to, 92

Grouping events, 57, 116–117
clearing, 117
creating new, 116
removing event from, 117

I

Installation, 11
system requirements, 10

K

Keyboard commands, 22–24
cursor placement, 23, 63
edit, 22
event, 23
miscellaneous, 24
playback, 23
project file, 22
track view, 23
view, 24
window view, 22

L

Labeling tracks,  See Naming tracks

Locking audio events, 54, 107

M

Main window, 16

Marker
deleting, 80
naming, 78
navigating, 79
placing and moving, 77

Marker bar, 17

Markers and regions, 77–87
enabling/disabling snapping, 93
snapping events to, 93

Media file
auto preview setting, 30
defined, 27
opening, 30
placing video, 32
previewing, 30
video placement options, 32

Media formats for import, 27

Mix to new, template, 140

Mix to preview, 43
status bar, 43

Mixer setup, 142

Mixer window, 21

Mixing multiple tracks to one track, 139
creating template, 140

Multiple takes
previewing, 148
recording, 148

Mute, 37

Muting a track, 129

N

Naming tracks, 126

Numbers
activation code, 13
serial, 13

O

Online help, 14
accessing, 15
icon, 14
INDEX
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PDF manual, 16
Tip of the day, 15
via the web, 16
What’s This? help, 15

Online registration, 13

Organizing tracks, 126

P

Panning, 39, 136–138

Panning envelopes
adding, 136
deleting from track(s), 138
hiding from track(s), 138
setting points, 137

Paste insert, 70

Paste repeat, 69

Pasting events, 68–70
ripple mode, 99

Pasting multitrack information
ripple mode, 100

Pasting track information
ripple mode, 100

PDF online manual, 16

Placing media
as takes, 31
double-clicking, 32
dragging/dropping, 31
multiple files, 31
same track, 31
separate tracks, 31

Playback
video, 52

Playback buttons  See Transport bar

Plug-in Chooser, 156

Presets, 158

Preview project, 41
entire, 42
media player, 43
mix to preview, 43
time selection, 42

Project properties, 43

Project, starting a, 28

Properties
events, setting, 101

Q

Quick start, 27–47
starting a project, 28

R

Recording, 141–154
choosing an active take, 149
deleting a take, 151
deleting active take, 151
deleting takes from list, 152
into a time selection, 145
into an event, 146
into an event with time selection, 147
into empty track, 144
multiple takes, 148
previewing takes, 148
renaming a take, 150
specifying storage folder, 153
starting and stopping, 143
track setup, 132

Redo command, 76
series of edits, 76

Redo/Undo commands, 74–77
clearing history, 77

Region, 80
deleting, 83
naming, 81
navigating, 82
placing and adjusting, 80
selecting, 81

Registering Vegas Pro
online, 13
telephone, 14

Renaming a project  Save As..., 45

Rendering a project, 46, 61
format options, 46, 61

Reordering tracks, 126
INDEX
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Ripple editing, 96–100
cutting events, 96
cutting time and event selection, 97
cutting time selection, 97
deleting events, 98
deleting time and event selection, 99
deleting time selection, 98
pasting events, 99
pasting multitrack information, 100
pasting track information, 100

Ruler, 18

S

Saving a project, 44, 60
options, 44

Scribble Strip, 37

Scrub control, 19

Selection Edit tool, 65

Serial Number, 13
 Title page

Shift key selecting, 64

Shortcut keys, See Keyboard commands

Snap offset, 91

Snapping events, 91–93
disabling, 93
snap offset, 91
to grid lines, 92
to marker lines, 93

Solo, 37

Soloing a track, 129

Sound editor program, 88–89
opening from Trimmer, 122
opening from Vegas Pro, 89
setting up, 88

Splitting, 94

Splitting events, 55

Starting Vegas Pro, 12

Switches, 105–110
locking an event, 107

looping an event, 108
muting an event, 106
normalizing an event, 109

Synching audio with video, 53, 56

System requirements, 10
common, 10
minimum, 10
recommended, 10

T

Target media player, previewing on, 43

Technical support, 10
email, 10
fax, 11
telephone number, 11
web site, 10

Technical support Title page

Telephone registration, 14

Time selection, 65
copying, 67
cutting, 71
deleting, 73
editing, 55
trim/crop, 72
with events, 66

Time selection, recording into, 145

Timeline
moving events along, 33, 40

Tip of the day help, using, 15

Toolbar, 17

Track effects, 36, 155

Track envelopes, 132–138
changing panning curves, 137
changing volume curves, 134
deleting from track(s), 135
hiding on track(s), 135

Track features, 123–140

Track FX
adding, 130

Track List, 18
INDEX



vi
Track Number, 35

Track panning envelopes
adding, 136
adding points, 136
deleting from track(s), 138
deleting points, 137
hiding on track, 138
resetting points, 137
setting points, 137

Track View, 19

Track volume envelopes
adding, 132
adding points, 133
colors defined, 132
deleting points, 133
resetting points, 133
setting points, 134

Tracks
adding empty, 123
arm for record button, 36
auxiliary bus, 39
auxiliary bus, adding, 130
auxiliary bus, assigning, 131
basics, 123
bus assignment, 36
color, changing, 127
defined, 27
deleting, 125
duplicating, 124
effects button, 36
expanding the view, 128
fader, using, 128
FX send, 39
FX, adding, 130
mixing to a single track, 139
multi-purpose slider, 38
mute button, 37
muting, 129
naming/renaming, 126
Number, 35
organizing, 126
panning, 39, 136–138
recording into, 132, 144
reordering, 126
routing to Assignable FX, 159

scribble strip, 37
selecting options, 64
solo button, 37
soloing, 129
view buttons, 35
view options, 127–128
volume slider, 38

Transport bar, 19, 41, 52
reference, 42

Trimmer window, 21, 118–122
event, placing, 119
event, placing from track, 119
events, placing from Explorer, 120
events, placing on track, 120
overview, 118
regions and markers, adding, 121
sound editor, opening from, 122
working with, 120

Trimming events, 72
time and event selection, 73
time selection, 72

Troubleshooting, 163–166

Tutorial, 49–62
aligning audio with video, 53, 56
editing time selection, 55
editing voice-over, 54
EQ settings, 59
event editing, 56
grouping audio and video, 57
placing music bed, 57
rending the project, 61
saving the project  (*.veg), 60
splitting an event, 55
video compression settings, 62
video placement, 50
video playback, 52
Video Preview window, 51
voice-over placement, 52
volume envelope, 58

Tutorial folder, copying, 49
INDEX



vii
U

Undo command, 74
series of edits, 75

Undo/Redo commands, 74–77
clearing history, 77

US contact information  Title page

V

Vegas Pro
project properties, 43
renaming a project, 45
rendering a project, 46
saving a project, 44
shortcut, 12
starting, 12

Vegas Pro overview, 16–25
Explorer window, 20
Keyboard commands, 22
Main window, 16
Marker bar, 17
Mixer window, 21
Ruler, 18
Scrub control, 19
Toolbar, 17
Track list, 18
Track view, 19
Transport bar, 19
Trimmer window, 21
Video preview window, 21
Windows Docking Area, 20

Video compression, 62

Video event
moving along timeline, 40
placement options, 32
placing, 32, 50
removing audio, 41

Video preview window, 21, 51

View buttons, 35

View options, tracks, 127–128

Volume
auxiliary bus fader, 131
track fader, 128

Volume envelope
setting points, 58, 134

Volume envelopes
adding, 58, 132–134
deleting from track(s), 135
hiding on track(s), 135
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